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Introduction

Welcome to the Revit Structure 2010 Families Guide! Families are an integral part of working in Revit Structure, and key
to creating custom content.

In this guide, you learn:

■ how to use families in your projects

■ concepts of parametric design and family creation

■ best practices to use when creating your own families

To better help you understand how to work with families, this guide contains conceptual explanations, hands-on tutorials,
and reference information.

Audience and Prerequisites

This guide is intended for the beginning, intermediate, and advanced Revit Structure families user. Although any sketching
and 2D or 3D modeling experience is helpful to understand how to work with families, before you begin to work with
this guide, you should have a basic understanding of Revit Structure. If you do not, it is recommended that you use the
tutorials included in the software. Access the tutorials by clicking Help ➤ Tutorials.

Training Files

The hands-on tutorials included in this guide use templates and family files that you download from
http://www.autodesk.com/revitstructure-familiesguide. Most of these files have an .rfa, .rte, or .rvt extension, and are extracted
by default to folders in C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2010Training Files (Windows
XP) or C:\Program Data\Autodesk\RST 2010Training Files (Windows Vista).

1
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Understanding Revit
Structure Families

All of the elements that you add to your Revit Structure projects – from the structural members, walls, roofs, windows,
and doors that you use to assemble a building model to the callouts, fixtures, tags, and detail components that you use
to document it – are created with families.

By using predefined families and creating new ones in Revit Structure, you can add both standard and custom elements
to your building models. Families also provide a level of control over elements that are similar in use and behavior, allowing
you to easily make design changes and manage your projects more efficiently.

What Are Families?
A family is a group of elements with a common set of properties, called parameters, and a related graphical
representation. Different elements belonging to a family may have different values for some or all of their
parameters, but the set of parameters (their names and meanings) is the same. These variations within the
family are called family types or types.

For example, the Structural Column category includes families and family types that you can use to create
different wide flanged, precast concrete, angle, and other columns. Although these families serve different
purposes and are composed of different materials, they have a related use. Each type in the family has a
related graphical representation and an identical set of parameters, called the family type parameters.

When you create an element in a project with a specific family and family type, you create an instance of
the element. Each element instance has a set of properties, in which you can change some element parameters
independent of the family type parameters. These changes apply only to the instance of the element, the
single element in the project. If you make any changes to the family type parameters, the changes apply to
all element instances that you created with that type.

Example: Creating a Structural Column Element with a Family and Type
When you create an element in a project, that element is organized within the project first by element
category, then by family, family type, and by instance. All 4 levels provide a different level of control of the
element in your project. The following example demonstrates how you can create and control a column in
a project.

2
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Determining the Element Category

All families that are in use or are available in your projects (and templates) are visible in the Project Browser
under Families, grouped by element category.

The category defines a top level of identification and behavior for the element. When you start the command
to create a structural column, you automatically determine that the element will belong to the Structural
Column category. The category sets the basic role of the element within the building model, determines
which elements it will interact with, and specifies that when tagged, it will be included in any graphical
column schedules that you create.

Selecting the Family

By expanding the Structural Columns category, you can see that it includes a number of different families.
All the structural columns that you create in this project (unless it is specialized or you load other families),
will belong to one of these families.

By itself, a family usually does not provide enough information to create a desired element in your project.
While the family narrows the definition of the element you are creating in terms of its basic characteristics
and graphic representation, it does not specify the size, material, or other specific characteristics of the
element. For this reason, families include family types.

Specifying the Family Type

Family types are variations on the kind of element the family represents, and are shown under the structural
column families shown below. For any of the types listed below, the family provides you with the kind of
structural column you want to create (precast concrete, angles, or drop capped, for example), while the
family type specifies the dimensions, material, and a few other characteristics of the element that you can
create.

4 | Chapter 2   Understanding Revit Structure Families



Creating an Instance

To add any of the column types in the Structural Columns family to a project, start the Component tool.
The Type Selector lists the available Structural Columns family types in the project, listed first by family,
then by name. You select the type that you want, and add it to the project.

When you create an element in your project, you create what is called an instance of the family type. If you
create one w-wide flange column element, you have one instance of the type in your project.

If you create four w-wide flange columns, you have four instances of the type in your project.

Example: Creating a Structural Column Element with a Family and Type | 5



Making Modifications

After you create an element in your project, you can make a number of changes to it. If you select one or
more instances of the column in the previous example, and then right-click and click Element Properties,
you display the Instance Properties of the column or columns. This is a location where you can make a
number of changes to the element and its parameters.

Changing Instance Parameters

In the Instance Properties dialog, under Instance Parameters, scroll down to view the instance parameters
of the column. You can change any of these values for the instance or instances of the column that you
selected. The changes will not be applied to all the columns of that type, only the instance or instances of
the column that you selected.

Changing Type Parameters

In the Instance Properties dialog, click Edit Type to view the Type Parameters of the w-wide flange column
type.

6 | Chapter 2   Understanding Revit Structure Families



These parameters are shared by all structural columns in the project of the same family type. Any changes
that you make to these parameters are applied to all structural columns of the same family type in the project,
regardless of whether or not you selected them.

Changing the Family or Family Type

You can also change the family type, or family and family type of the column element in the Instance
Properties dialog.

To change the family, at the top of the dialog, for Family, select a new family. In this example, you could
change the column family to one that creates a different style of column or you could change the w-wide
flange column to a completely different column, like a precast column with a rectangular fork bearing.

To change the family type, for Type, select a different type. After you exit the dialog, the instance or instances
that you selected will reflect any changes that you made to the family or family type.

Role of Families in Your Building Models
Now that you have seen the control that you have over elements that you create with families and family
types, you can imagine the flexibility that families, family types, and family parameters provide when
creating and documenting your building models. Families, family types, and type and instance parameters
allow for variation and change in the elements that you create, which is the basis of parametric modeling
in Revit Structure.

In addition to making the changes that were demonstrated in the previous section, you can use families,
family types, and family parameters to:

■ Add family types to existing families.

■ Create your own family, and by adding family types, create a number of the same elements in a different
size or that feature a different material, without having to draw the component more than once.

Role of Families in Your Building Models | 7



■ Create family type parameters in a family that provide optional element geometry or material.

■ Control the visibility and detail level of an element in different types of drawing views.

All families can be two-dimensional, three-dimensional, or both, but not all families have to be parametric.
Elements created with families that do not need more than one size or type may remain non-parametric.

Wall, door, and window families are examples of 3D families, which display accordingly in isometric and
plan views. Annotation detail families are examples of 2D families that do not require 3D representations.
A furniture family is an example of a family that might need separate 3D and 2D representations: a 3D
representation to display in isometric views and a simplified 2D outline to display in a plan view.

NOTE Two- and three-dimensional content from other software packages that you import into Revit Structure is
not parametric, unless you recreate it as such.

Different Kinds of Families
There are 3 kinds of families in Revit Structure:

■ system families

■ loadable families

■ in-place families

Most elements that you create in your projects are system families or loadable families. Loadable families
can be combined to create nested and shared families. Non-standard or custom elements are created using
in-place families.

System Families
System families create basic building elements such as walls, roofs, ceilings, floors, and other elements that
you would assemble on a construction site. System settings, which affect the project environment and
include types for levels, grids, drawing sheets, and viewports, are also system families.

System families are predefined in Revit Structure. You do not load them into your projects from external
files, nor do you save them in locations external to the project. If you cannot find the system family type
that you need in a project, you can create a new one by changing the properties of an existing type, by
duplicating (copying) a family type and changing its properties, or by copying and pasting one from another
project. Any types that you modify are saved in your project.

Because system families are predefined, they are the least customizable of the 3 kinds of families, but they
include more intelligent behavior than the other standard component families and in-place families. A wall
that you create in a project automatically resizes to accommodate windows and doors that you place in it.
There is no need to cut openings in the wall for the windows and doors before you place them.

Loadable Families
Loadable families are families used to create both building components and some annotation elements.
Loadable families create the building components that would usually be purchased, delivered, and installed
in and around a building. They also include some annotation elements that are routinely customized, such
as symbols and titleblocks.

Because of their highly customizable nature, loadable families are the families that you most commonly
create and modify in Revit Structure. Unlike system families, loadable families are created in external .rfa
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files and imported, or loaded, in your projects. For families that contain many types, you can create and use
type catalogs, which allow you to load only the types that you need for a project.

When you create a loadable family, you begin with a template that is supplied in the software and contains
information about the family that you are creating. You sketch the geometry of the family, create parameters
for the family, create the variations or family types that it includes, determine its visibility and detail level
in different views, and test it before using it to create elements in your projects.

Revit Structure includes a library of content in which you can both access loadable families that are supplied
by the software and save the families that you create. You can also access loadable families from various
sources on the Web.

Nesting and Sharing Loadable Families

You can load instances of families in other families to create new families. By nesting existing families inside
other families, you can save yourself modelling time.

Depending on how you want instances of these families to act when you add them to your projects (as single
element or as individual elements), you can specify whether the nested families are shared or not shared.

In-Place Families
In-place elements are unique elements that you create when you need to create a unique component that
is specific to the current project. You can create in-place geometry so that it references other project geometry,
resizing or adjusting accordingly if the referenced geometry changes. Examples of in-place elements are:

■ unique or unusual geometry, such as a non-standard slab

■ a custom component that you do not plan to reuse

A truss created as an in-place family

■ geometry that must reference other geometry in your project
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A step footing created as an in-place family

■ a family that does not require multiple family types

In-place elements are created similarly to loadable families, but like system families, are not loaded from or
saved to external files. They are created in the context of the current project, and are not intended to be
used in other projects. They can be 2D or 3D, and by selecting a category in which to create them, can be
included in schedules. Unlike system families and loadable families, however, you cannot duplicate in-place
family types to create multiple types.

Although it may seem easier to create all your components as in-place elements, the best practice is to use
them only when necessary. In-place elements can increase file size and degrade software performance.

Design Environment for Creating Families
The Family Editor is a graphical editing mode in Revit Structure that lets you create and modify the families
to include in your project. When you start creating a family, you open a template to use in the editor. The
template can include multiple views, such as plans and elevations. The Family Editor has the same look and
feel as the project environment in Revit Structure, but it features different tools.
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A pile cap family as seen in the Family Editor

The Family Editor is not a separate application. You access the Family Editor when you create or modify the
geometry of a loadable family or an in-place family.

Unlike system families, which are predefined, loadable and in-place families are always created in the Family
Editor. However, system families may contain loadable families that are modifiable in the Family Editor.
For example, wall system families may include profile component family geometry to create openings,
stiffeners, or plate connections.
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Loadable Families
Overview

Loadable families are families used to create building components and annotation elements. Loadable families create the
building components that would usually be purchased, delivered, and installed in and around a building, such as windows,
doors, casework, fixtures, furniture, and planting. They also include some annotation elements that are routinely customized,
such as symbols and titleblocks.

Because of their highly customizable nature, loadable families are the families that you most commonly create and modify
in Revit Structure. Unlike system families, loadable families are created in external .rfa files and are imported (loaded) into
projects. For families that contain many types, you can create and use type catalogs, which let you load only the types
that you need for a project.

When you create a loadable family, you begin with a template that is supplied in the software and contains information
about the family that you are creating. You sketch the geometry of the family, use parameters to establish relationships
between family components, create the variations or family types that it includes, and determine its visibility and detail
level in different views. When you finish the family, you test it in a sample project before using it to create elements in
your projects.

Revit Structure includes a library of content in which you can both access families that are supplied by the software and
save the loadable families that you create. You can also access loadable families from manufacturers’ web sites and from
Autodesk® Seek.

Nesting and Sharing Loadable Families

You can load instances of families in other loadable families to create new families. By nesting existing families inside
other families, you can save yourself modelling time.

Depending on how you want instances of these families to act when you add them to your projects (as single element or
as individual elements), you can specify whether the nested families are shared or not shared.

Creating Loadable Families
Using Revit Structure, you can create families for a project. The software provides many templates, including
those for structural members and lets you graphically draw the new family. The templates contain much of
the information that you need to start creating the family and that Revit Structure needs to place the family
in projects.

3
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Understanding the Family Editor
The Family Editor is a graphical editing mode in Revit Structure that allows you to create families to include
in your project. When you start creating a family, you open a template to use in the Family Editor. The
template can include multiple views, such as plan and elevation views. The Family Editor has the same look
and feel as the project environment in Revit Structure, but features different tools located on a single Create
tab.

You can access the Family Editor by:

■ Opening or creating a new family (.rfa) file.

■ Selecting an element created by a loadable or an in-place family type, and then right-clicking and clicking
Edit Family.

Family Editor Tools

■ The Types tool (Create tab ➤ Family Properties panel ➤ Types) opens the Family Types dialog. You can
create new family types or new instance and type parameters. See Creating Family Types on page 28.

■ The Dimension tool (Detail tab ➤ Dimension panel) add permanent dimensions to the family, in addition
to ones that Revit Structure automatically creates as you draw the geometry. This is important if you
wish to create different sizes of the family.

■ The Model Line tool (Create tab ➤ Model panel ➤ Model Line) lets you draw two-dimensional geometry
for when you do not need to show solid geometry. For example, you could draw door panels and
hardwareduct as 2D rather than use solid extrusions. Model lines are always visible in 3D views. You can
control their visibility in plan and elevation views by selecting the lines and clicking Modify Lines
tab ➤ Visibility panel ➤ Visibility Settings.

■ The Symbolic Line tool (Detail tab ➤ Detail panel ➤ Symbolic Line) lets you draw lines that are meant
for symbolic purposes only. Symbolic lines are not part of the actual geometry of the family. Symbolic
lines are visible parallel to the view in which you draw them.
You can control symbolic line visibility on cut instances. Select the symbolic line, and click Modify Lines
tab ➤ Visibility panel ➤ Visibility Settings. In the Family element visibility settings dialog, select Show
only if instance is cut.
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In this dialog, you can also control the visibility of lines based on the detail level of the view. For example,
if you select Coarse, the symbolic lines are visible when you load the family into a project and place it
in a view at the Coarse detail level.

TIP Use this dialog to control visibility of generic annotations loaded into model families. See Loading Generic
Annotations into Model Families on page 66.

■ The Opening tool (Create tab ➤ Model panel ➤ Opening) is available in host-based family templates
only . You create an opening by sketching its shape to the reference planes and then modifying its
dimensions. After you create an opening, you can select it and set it to display as transparent in 3D and/or
elevation views when loaded into a project. You specify transparency on the Options Bar.

NOTE The Opening tool is also available in the project environment.

■ The Reference Plane tool (Create tab ➤ Datum panel ➤ Reference Plane) creates a reference plane, which
is an infinite plane that serves as a guide for drawing lines and geometry.

■ The Reference Line tool (Create tab ➤ Datum panel ➤ Reference Line) creates a line similar to a reference
plane, but that has logical start and end points.

■ The Control tool (Create tab ➤ Control panel ➤ Control) lets you place arrows to rotate and mirror the
geometry of a family, after you add it to your design. The following arrow controls are available on the
Place Control tab ➤ Control Type panel (multiple selections are acceptable):

■ Single Vertical

■ Double Vertical

■ Single Horizontal

■ Double Horizontal

Revit Structure rotates or mirrors the geometry about the origin. With 2 opposite-facing arrows, you can
mirror horizontally or vertically.

You can place the controls anywhere in the view. It is best to place them where it is obvious what they
control.

■ The Text tool (Detail tab ➤ Annotate panel ➤ Text) lets you add text notes to the family. This is typically
used in an annotation family.

■ The Section tool (View tab ➤ View Creation panel ➤ Section) lets you create a section view.

■ The Component tool (Create tab ➤ Model panel ➤ Component) selects the type of component to be
inserted into the Family Editor. After you select this tool, the Type Selector becomes active and you can
select a component.

■ The Symbol tool (Detail tab ➤ Detail panel ➤ Symbol) lets you place 2D annotation drawing symbols.

■ The Detail Component tool (Detail tab ➤ Detail panel ➤ Detail Component) lets you place a detail
component.

■ The Masking Region tool (Detail tab ➤ Detail panel ➤ Masking Region) lets you apply a mask that will
obscure model elements when the family is used to create an element in a project. See Masking Regions
in the Revit Structure 2010 Help.

■ The Solid tool (Create tab ➤ Forms panel ➤ Form) provides access to tools that let you create solid
geometry in the family.

■ The Void tool (Create tab ➤ Forms panel ➤ Void) provides access to tools that let you cut solid geometry
in the family.
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■ The Label tool (Create tab ➤ Annotate panel ➤ Label) lets you place intelligent text in the family. This
text represents a family property. When the property value is specified, it will show up in the family.

NOTE This tool is available for annotation symbols only.

■ The Load into Project tool (Create tab ➤ Family Editor panel ➤ Load Into Project) lets you load a family
directly into any open project or family.

Creating a Loadable Family
Typically, the loadable families that you need to create are standard sizes and configurations of common
components and symbols used in a building design.

To create a loadable family, you define the geometry and size of the family using a family template that is
provided in Revit Structure. You can then save the family as a separate Revit family file (.rfa file) and load
it into any project.

Depending on the complexity of the family, the creation process can be time-consuming. If you can identify
a family that is similar to the one you want to create, you can save time and effort by copying, renaming,
and modifying the existing family.

The topics in this section apply to the creation of model (3D) families, but some are relevant to 2D families,
including titleblocks, annotation symbols, and detail components.

Workflow: Creating a Loadable Family
For best results when creating a loadable family, follow the workflow below.

1 Before beginning family creation, plan the family.

See Planning a Loadable Family on page 17.

2 Create a new family file (.rfa) using the appropriate family template.

See Choosing a Family Template on page 17.

3 Define subcategories for the family to help control the visibility of the family geometry.

See Creating Family Subcategories on page 20.

4 Create the family skeleton, or framework:

■ Define the origin (the insertion point) of the family.
See Defining the Family Origin on page 22.

■ Lay out reference planes and reference lines to aid in sketching component geometry.
See Laying Out Reference Planes on page 23 and Using Reference Lines on page 25.

■ Add dimensions to specify parametric relationships.
See Dimensioning Reference Planes on page 26.

■ Label dimensions to create type or instance parameters or 2D representation.
See Labeling Dimensions to Create Parameters on page 26.

■ Test, or flex, the framework.
See Flexing the Family Framework on page 27.

5 Define family type variations by specifying different parameters.

See Creating Family Types on page 28.
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6 Add a single level of geometry in solids and voids, and constrain the geometry to reference
planes.

See Creating Family Geometry on page 30.

7 Flex the new model (types and hosts) to verify correct component behavior.

See Flexing the Family on page 29.

8 Repeat previous steps until the family geometry is complete.

9 Specify 2D and 3D geometry display characteristics with subcategory and entity visibility settings.

See Managing the Family Visibility and Detail Level on page 59.

10 Save the newly defined family, and then load it into a project for testing.

See Testing a Family in a Project on page 60.

Planning a Loadable Family
If you consider this list of requirements before creating a family, you will have an easier time creating it.
Because there are bound to be changes as you create families, the Family Editor lets you make those changes
without having to start over.

■ Will the family need to accommodate multiple sizes?
For a beam that is available in several preset sizes, or a truss that is available in several different shapes,
create a standard component family. However, if you need to create a custom piece of reinforcement
that only comes in one configuration, you may want to create it as an in-place family, instead of a
loadable family.

Size variability and the degree of complexity of the object determine whether you create a loadable family
or an in-place family.

■ How should the family display in different views?
The way the object should display in views determines the 3D and 2D geometry that you need to create,
as well as how to define the visibility settings. Determine whether the object should display in a plan
view, elevation view, and/or section views.

■ Does this family require a host?
For objects typically hosted by other components, such as rebar, start with a host-based template. How
the family is hosted (or what it does or does not attach to) determines which template file should be
used to create the family.

■ How much detail should be modeled?
In some cases, you may not need 3D geometry. You may only need to use a 2D shape to represent the
family. Also, you may simplify the 3D geometry of the model to save time in creating the family.

■ What is the origin point of this family?
For example, the insertion point for a column family could be the center of the circular base. Determining
the appropriate insertion point will help you place the family in a project.

Choosing a Family Template
After you plan a family, your next step is to choose the template that you will base it on. When you create
a family, you are prompted to select a family template that corresponds to the type of element that the
family will create.

The template serves as a building block, containing the information that you need to start creating the
family and that Revit Structure needs to place the family in projects.
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Different Kinds of Family Templates
While most of the family templates are named according to the type of element family created from them,
there are a number of templates that include one of the following descriptors after the family name:

■ wall-based

■ floor-based

■ roof-based

Wall-based, floor-based, and roof-based templates are known as host-based templates. A host-based family
can be placed in a project only if an element of its host type is present.

Review the following template descriptions to determine which one best suits your needs.

Wall-based Templates

Use the wall-based templates to create components that will be inserted into walls. Some wall components
(such as doors and windows) can include openings, such that when you place the component on a wall, it
cuts an opening in the wall. Some examples of wall-based components include doors, windows, and lighting
fixtures. Each template includes a wall; the wall is necessary for showing how the component fits in or on
a wall.

Floor-based Template

Use the floor-based template for components that will be inserted into floors. Some floor components (such
as a heating register) include openings, so that when you place the component on a floor, it cuts an opening
in the floor.

Roof-based Template

Use the roof-based template for components that will be inserted into roofs. Some roof components include
openings, so that when you place the component on a roof, it cuts an opening in the roof. Examples of
roof-based families include soffits and fans.

Standalone Template

Use the standalone template for components that are not host-dependent. A standalone component can be
placed anywhere in a model and can be dimensioned to other standalone or host-based components.
Examples of standalone families include columns, furniture, and appliances.

Line-based Template

Use the line-based templates to create detail and model families that use 2-pick placement.

Face-based Template

Use the face-based template to create work plane-based families that can modify their hosts. Families created
from the template can make complex cuts in hosts. Instances of these families can be placed on any surface,
regardless of its orientation. See Creating Work Plane-based and Face-based Families on page 68.

Creating a Family with a Template
To create a loadable family, you select a family template, and then name and save the family file. Name the
family so it adequately describes the element that it is intended to create. Later, when the family is complete
and you load it into a project, the family name displays in the Project Browser and the Type Selector.

Predefined imperial and metric component families are installed by default in library folders:

18 | Chapter 3   Loadable Families Overview



Windows XP: C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2010\Imperial Library
or Metric Library.

Windows Vista: C:\Program Data\Autodesk\RST 2010\Imperial Library or Metric Library.

You can save families in the folders in these libraries, or you can save them to any local or network location.
After you create families, you can use the Copy and Paste commands in Microsoft® Windows Explorer to
move the families to different locations.

BEST PRACTICE  Do not save the family to a location where others can access it until you complete and test the
family.

To create a family with a template

1 Click  ➤ New ➤ Family.

NOTE If you are creating an annotation or titleblock family, click  ➤ New ➤ Annotation Symbol
or Title Block.

Depending on the current drawing units, the New Family - Select Template File dialog displays
the available imperial or metric family templates that are installed on your system in:

Windows XP: C:\Documents and Settings\All Users\Application Data\Autodesk\RST
2010\Imperial Templates or Metric Templates.

Windows Vista: C:\Program Data\Autodesk\RST 2010\Imperial Templates or Metric Templates.

NOTE Depending on your software installation or office standards, the family templates may be
installed in another location, either locally or on a network. Contact your CAD Manager for more
information.

2 Optionally, to preview a template, select it.

The template preview image displays in the upper right corner of the dialog.

3 Select the family template that you want to use, and click Open.

The new family opens in the Family Editor. For most families, 2 or more dashed green lines
display. These are reference planes, or the working planes that you will use when you create the
family geometry.

If you are creating a host-based family, such as a window family, host geometry may also display.
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4 In the Project Browser, notice the list of family views.

The family views vary depending on the type of family that you create. If necessary, you can
create additional views by duplicating and renaming existing views.

5 Click  ➤ Save As ➤ Family.

6 In the Save dialog, navigate to the location in which you want to save the family, enter a name
for the family, and click Save.

BEST PRACTICE  Use title case for the family name.

Creating Family Subcategories
When you create a family, the template assigns it to a category that defines the default display of the family
(line weight, line color, line pattern, and material assignment of the family geometry) when the family is
loaded into a project. To assign different line weights, line colors, line patterns, and material assignments
to different geometric components of the family, you need to create subcategories within the category. Later,
when you create the family geometry, you assign the appropriate components to the subcategories.

Revit Structure features some predefined subcategories for different categories of families. Other families
have no subcategories, which means that you can define your own. The Object Styles dialog lists family
categories and subcategories. It also displays the line weight, line color, line pattern, and material assigned
to each category and subcategory.

TIP You can apply a drafting pattern to a family. When you create and define a subcategory to apply to the family,
you can specify its surface and cut pattern materials to have a drafting pattern. You cannot apply a model pattern
to a family. Only flat or cylindrical surfaces can have drafting patterns. See Fill Patterns in the Revit Structure 2010
Help.

1 With the family open, click Manage tab ➤ Family Settings panel ➤ Settings drop-down ➤ Object
Styles.

2 On the Model Objects tab of the Object Styles dialog, under Category, select the family category.

3 Under Modify Subcategories, click New.

4 In the New Subcategory dialog, for Name, enter a new name.

Revit Structure automatically selects the appropriate category in the Subcategory of list.
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5 Click OK.

Although you will not immediately create and assign the subcategory to the family geometry,
you can specify the line weight, line color, line pattern, and material for the subcategory.

6 Specify values for line weight, line color, line pattern, and material:

■ Click in the Projection and Cut fields for Line Weight, and select values from the lists.

■ Click the button in the Line Color field, and select a color from the Color dialog. If desired,
define a custom color.

■ Click in the Line Pattern field, and select a line pattern from the list. If desired, define a new
line pattern for the line display.

■ Click in the Material field, and specify a material, cut pattern, surface pattern, or render
appearance.
See Materials in the Revit Structure 2010 Help.

7 To define additional subcategories, repeat steps 3 - 6.

8 Click OK.

Creating the Family Framework
After you plan a family, the next step is to create the family framework (skeleton). The framework is comprised
of lines and parameters in which you later create the family geometry. It also defines the origin (insertion
point) of elements that you create with the family.

To create the framework, you begin by defining the family origin. You then build the framework with
elements called reference planes and reference lines. Next you define family parameters. The parameters
that you define at this stage usually control the size (length, width, height) of the element, and let you add
family types.

A view of a  truss family framework

When the framework is complete, you test it by changing the parameter values and ensuring that the
reference planes resize. By creating solid frameworks from the information that you gather in your planning
stage before you create the family geometry, you ensure the stability of the families that you create.
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Defining the Family Origin
After you create a component family, define the family origin and pin (lock) it in place. Later, when you
create an element with the finished family, the family origin specifies the element insertion point.

The intersection of 2 reference planes in a view defines the origin of a family. You can control which reference
planes define the origin by selecting them and changing their properties. Many family templates create
families with predefined origins, but you may need to set the origin of some families.

To define the family origin

1 In the Family Editor, verify whether an origin has been defined for the family by selecting the
reference planes.

If a pin displays on 2 of the reference planes, the origin is defined for the family, and you can
skip the remaining steps.

2 Click Create tab ➤ Datum panel ➤ Reference Plane drop-down ➤  Draw Reference Plane.

3 Sketch the reference plane.

4 Select the reference plane.

5 Click Modify Reference Planes tab ➤ Element panel ➤ Element Properties drop-down ➤ Instance
Properties.
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6 In the Instance Properties dialog, under Other, select Defines Origin, and then click OK.

7 Create or open a family.

8 In a plan view, while pressing Ctrl, select both reference planes.

9 Click Multi-Select tab ➤ Modify panel ➤ Pin.

10 With the reference planes still selected, access their instance properties.

11 In the Instance Properties dialog, under Other, select Defines Origin.

The intersection of the reference planes now defines the origin/insertion point of the family.
By pinning the planes, you ensure that you do not accidentally move them, which would change
the family insertion point.

Laying Out Reference Planes
Before you create family geometry, you should sketch reference planes. You can then snap sketches and
geometry to the reference planes.

■ Position new reference planes so that they align with the major axes of the planned geometry.

■ Name each reference plane so that you can assign it to be the current work plane. The name lets you see
the reference plane so that you can select it to use as a work plane.

■ Specify the property for reference planes that lets you dimension to them when the family is placed in
a project.

A metal deck family created within a framework of reference planes

To lay out reference planes

1 Click Create tab ➤ Datum panel ➤ Reference Plane drop-down ➤ Draw Reference Plane.

2 Specify a start point and an end point for the reference plane.

3 Name the reference plane so that you can identify it in when you open other views:

■ Select the reference plane, and click Modify Reference Planes tab ➤ Element panel ➤ Element
Properties drop-down ➤ Instance Properties.

■ In the Instance Properties dialog, under Identity Data, for Name, enter a name for the reference
plane.

■ Click OK.
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Defining Priorities for Reference Planes
Reference planes have a property called Is Reference. By setting this property or by defining a plane as an
origin, you specify that the reference plane can be dimensioned to when you place a family into a project.

Is Reference also sets a reference point for dimensions when you use the Align tool. Specifying the Is Reference
parameter lets you select different lines of aligned components for dimensioning.

Available Is Reference values:

■ Not a reference

■ Strong reference (see Specifying Strong and Weak References on page 24.)

■ Weak reference (see Specifying Strong and Weak References on page 24.)

■ Left

■ Center (Left/Right)

■ Right

■ Front

■ Center (Front/Back)

■ Back

■ Bottom

■ Center (Elevation)

■ Top

If you create multiple families with the same Is Reference value for a particular reference plane, the dimensions
to that reference plane apply when you switch between family components.

Specifying Strong and Weak References
To dimension families placed in a project, you need to define family geometry references as either strong
or weak in the Family Editor.

A strong reference has the highest priority for dimensioning and snapping. As you are placing the family,
temporary dimensions snap to any strong references in the family. When you select the family in the project,
temporary dimensions appear at the strong references.

A weak reference has the lowest priority for dimensioning. When you place the family into the project and
dimension to it, you may need to press Tab to select a weak reference, as any strong references highlight
first.

NOTE You may also be able to zoom in to the model to highlight weak references, as elements in the model
appear farther apart as you zoom in.

This procedure changes references for selected line instances. It does not specify reference values for new
lines.

1 Click Create tab ➤ Datum panel ➤ Reference Line (or Reference Plane), and sketch a line or
reference plane.

2 Select the line or plane, and click Modify <element> tab ➤ Element panel ➤ Element Properties
drop-down ➤ Instance Properties.
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3 For reference line, in the Instance Properties dialog, for Is Reference, select Strong Reference.
For a reference plane, for Is Reference, select Strong Reference.

NOTE The default reference property for all reference planes and sketched lines is Weak Reference.

4 Click OK.

You can sketch lines and specify them as strong references. To create strong references for solid geometry,
such as extrusions, sketch reference planes and specify them as strong references. Then sketch the solid
geometry to the reference planes.

Using Reference Lines
You can use reference lines to create a parametric family framework to which elements of the family can
attach.

Reference lines are annotation objects with their own category. When selected, they display dual faces.
When printing, their visibility is affected by the Hide ref/work planes option.

Straight reference lines provide 2 planes for you to sketch on, one that is parallel to the work plane of the
line and one that is perpendicular to that plane. Both planes go through the reference line. The planes
display when the reference line is selected or highlighted, or when you use the Work Plane tool. When
selecting a work plane, you can place the cursor over a reference line and press Tab to switch between the
2 faces. The plane in which the line was sketched always displays first. You can also create arc reference
lines, but they do not define planes.

Reference Line Behavior in the Project

After a family is loaded into a project, the behavior of reference lines is identical to that of reference planes.
Reference lines are not visible in a project and do not highlight when the family instance is selected. They
highlight and generate shape handles in the same contexts as reference planes currently do, depending on
their Reference property.

Selected reference in multiple views

Controlling Angular Dimensions with Reference Lines
The preferred method to control the angular dimensions of a family is to apply a labelled angular dimension
to a reference line. Unlike reference planes (with infinite extents), a reference line has specific start and end
points and can be used to control the angular constraints within components (such as a web truss or a door
with a instance door swing).
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To add and dimension a reference line

1 In the drawing area (while in the Family Editor), add a reference line with the point of origin
located at the point of expected rotation.

2 Add an angular dimension referring to the reference line.

3 Label the dimension.

4 Click Family Properties panel ➤ Types.

5 In the Family Types dialog, change the angular value for the labelled dimension, and click Apply.

This is known as flexing the model. It is important to make sure the reference line adjusts as
expected before adding model geometry to it.

To add and align model geometry to a reference line

6 Set the current work plane to one of the faces of the reference line.

7 Add the model geometry that you intend to have controlled by the angular dimension.

8 Flex the model to make sure the design works as expected.

The geometry moves with the reference line as the angle changes.

Adding Parameters to the Family Framework
Although you have not yet created any family geometry, you can define the main parametric relationships
in the family. The parameters that you define at this stage usually control the size (length, width, height)
of the element. To create a parameter, you place dimensions between the reference planes of the framework
and then label them.

IMPORTANT Families in Revit Structure are not parametric until you add labeled dimensions to them.

Dimensioning Reference Planes
The first step to creating family parameters is to place dimensions between the reference planes of the
framework to mark the parametric relationships that you intend to create. Dimensions alone do not create
the parameters; you must label them to create parameters.

1 Identify the reference planes that you want to dimension to create parameters.

2 Click Detail tab ➤ Dimension panel, and select a dimension type.

3 On the Options Bar, select an option for placing dimensions.

4 Place the dimensions between reference planes.

5 Continue to dimension reference planes until all the parametric relationships have been
dimensioned.

TIP You may need to open different views in the family to create some of the dimensions.

Labeling Dimensions to Create Parameters
After you dimension the family framework, you label the dimensions to create parameters. For example, the
dimensions below have been labeled with length and width parameters.
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If the parameters exist in the family, you can select any of them as a label. If not, you must create the
parameter, specifying its type and whether it is an instance or type parameter.

To label dimensions and create parameters

1 While in the Family Editor, right-click the dimension, and click Edit Label.

2 Select a parameter from the list, or choose <Add parameter...>, and create a parameter.

See Creating Parameters on page 51.

TIP You can add formulas to parameters. A simple example would be a width parameter that is
specified as twice the height of the object. See Using Formulas for Numerical Parameters on page
54.

Alternate procedure for labeling

1 While in the Family Editor, select the dimension value.

2 On the Options Bar, for Label, select a parameter, or create a parameter. See Creating Parameters
on page 51.

3 If desired, select Leader to create a leader line for the dimension.

Flexing the Family Framework
You can flex, or test, the parameters that you have applied to the family framework. To flex the framework,
you adjust the parameter values, making sure that the reference planes to which you applied the parameter
change accordingly. Flexing is a way to test the integrity of the parametric relationships. Flexing early and
often as you create families ensures the stability of the families.

To flex the framework

1 Click Create tab ➤ Family Properties panel ➤ Types.

The Family Types dialog displays. Although you have not defined any family types yet, the
dialog lists the parameters that you created.

2 Reposition the Family Types dialog on the screen, so you can view the framework.
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3 In the Family Types dialog, under Parameter, locate the parameters that you created previously,
and enter different values in each corresponding Value field.

4 Click Apply.

The family framework should adjust to reflect the updated parameter values.

5 Continue to flex the framework by specifying different parameter values.

The more extensively you test the parameters, the more likely you are to create a stable family.

6 When you finish flexing the framework, click OK.

Creating Family Types
Using the Family Types tool, you can create many types (sizes) for a family. To do this, you need to have
labeled the dimensions and created the parameters that are going to vary.
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Each family type has a set of properties (parameters) that includes the labeled dimensions and their values.
You can also add values for standard parameters of the family (such as Material, Model, Manufacturer, Type
Mark, and others).

To create family types

1 Click Create tab ➤ Family Properties panel ➤ Types.

2 In the Family Types dialog, under Family Types, click New.

3 Enter the family name, and click OK.

4 In the Family Types dialog, enter the values for the type parameters.

5 Click OK.

Flexing the Family
After you create family types, you can flex, or test, the family. To flex the family, you switch between different
family types, ensuring that the family adjusts properly. You can flex the family before and after you create
the family geometry. Flexing early and often as you create families ensures the stability of the families.

To flex the family

1 Click Create tab ➤ Family Properties panel ➤ Types.

2 Reposition the Family Types dialog on the screen, so you can view the family framework.

3 At the top of the dialog, select a family type, and then click Apply.

The family should adjust to reflect the parameter values specified in the selected family type.
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4 Continue to flex the family by selecting each type in the family.

5 When you finish flexing the family, click OK.

Creating Family Geometry
You can use both 2- and 3-dimensional geometry to create families. Create solid geometric shapes to represent
the element that the family is intended to create. Use 2D linework to add detail to solid geometry in certain
views or to create a symbolic plan representation of an element.

As you create the family geometry, you can specify the visibility, material, and an optional subcategory of
the geometry. These settings determine how and when the specific geometric components of the family
display.

To ensure the stability of each parametric family, build the family geometry incrementally, testing (flexing)
the parametric relationships in each increment.

Creating Solid (3D) Geometry
To create solid family geometry, you use 3-dimensional solid and void forms. Solid forms are 3D shapes that
represent the solid geometry of a family.
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Extrusion of a concrete
isolated foundation

Void forms are 3D shapes that you use to cut volume from solid forms, allowing you to create complex solid
forms. You can sketch void forms at the location where you want them to cut solid forms, or you can move
them after you create them and then use the Cut Geometry tool to perform the cut.

You can also use the Join Geometry tool to join solid geometry to create complex forms.

The Family Editor provides you with tools that you can use to create solid and void forms. Access these tools
from the Create tab ➤ Forms panel by clicking Solid or Void. The tools offer 5 methods that you can use to
create both solid and void geometry: extrusions, blends, revolves, sweeps, and swept blends. Both sweeps
and swept blends use profiles swept along a path; to create profile families that you can load and use, see
Creating and Using Profile Families on page 46.
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NOTE You can also create extrusions, blends, revolves, sweeps, and swept blends as mass families. See Conceptual
Design with Massing Studies in the Revit Structure 2010 Help.

When you create geometry, you can determine how it displays in the family:

■ Specify the visibility and detail level of the geometry.
See Managing the Family Visibility and Detail Level on page 59.

■ Assign a material to the geometry.
See Material in the Revit Structure 2010 Help.

■ Assign the geometry to a subcategory.
See Creating Family Subcategories on page 20 and Assigning Family Geometry to Subcategories on page
58.

Creating an Extrusion
A solid or void extrusion is the easiest form to create. You sketch a 2D profile of the form on a work plane,
and then extrude that profile perpendicular to the plane on which you sketched it.

Sample polygonal concrete
isolated foundation extrusion

Before you extrude the shape, you can specify its start and end points to increase or decrease the depth of
the form. By default, the extrusion start point is 0. The work plane does not need to be either the start or
end point of the extrusion – you only use it to sketch on and to set the extrusion direction.

The following procedure is a general method for creating a solid or void extrusion. Steps may vary depending
on your design intent.

To create a solid or void extrusion

1 In the Family Editor, on the Create tab ➤ Forms panel, do one of the following:

■ Click Solid drop-down ➤ Extrusion.

■ Click Void drop-down ➤ Extrusion.

NOTE If necessary, set the work plane before you sketch the extrusion. Click Create tab ➤ Work
Plane panel ➤ Set.
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2 Use the sketching tools to sketch the extrusion profile:

■ To create a single solid form, sketch a closed loop.

■ To create more than one form, sketch multiple, non-intersecting, closed loops.

3 To extrude the profile from the default start point of 0, on the Options Bar, for Depth, enter a
positive or negative extrusion depth.

This value changes the endpoint of the extrusion.

NOTE The extrusion depth is not retained after you create the extrusion. If you need to make multiple
extrusions with the same endpoint, sketch the extrusions, select them, and then apply the endpoint.

4 Specify the extrusion properties:

■ Click Create Extrusion tab ➤ Element panel ➤ Extrusion Properties.

■ To extrude the extrusion from a different start point, under Constraints, for Extrusion Start,
enter a new point.

■ To set the visibility of a solid extrusion, under Graphics, for Visibility/Graphics Overrides,
click Edit, and specify the visibility settings.

■ To apply a material to a solid extrusion by category, under Materials and Finishes, click in

the Material field, click  , and specify a material.

■ To assign a solid extrusion to a subcategory, under Identity Data, for Subcategory, select a
subcategory.

■ Click OK.

5 Click Create Extrusion Boundary tab ➤ Extrusion panel ➤ Finish Extrusion.

Revit Structure completes the extrusion and returns you to the view in which you started the
extrusion.

6 To view the extrusion, open a 3D view.

7 To resize the extrusion in the 3D view, select it and use grips to edit it.

Editing an Extrusion
You can modify an extrusion after creating it.

To edit an extrusion

1 In the drawing area, select the extrusion.

2 If you are in the project environment:

a Click Modify <Element> tab ➤ Family panel ➤ Edit Family.

b Click Yes to open the family for editing.

c In the Family Editor, select the extrusion in the drawing area again.

3 Click Modify Extrusion tab ➤ Form panel ➤ Edit Extrusion.

4 If desired, modify the extrusion profile.

5 To edit the extrusion properties, click Modify Extrusion > Edit Extrusion tab ➤ Element
panel ➤ Extrusion Properties, and change the visibility, material, or subcategory of the extrusion.
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6 To change the extrusion to a solid or a void, under Identity Data, for Solid/Void, select Solid or
Void.

7 Click OK.

8 Click Finish Extrusion.

Creating a Blend
The Blend tool blends 2 profiles (boundaries) together. For example, if you sketch a large rectangle and a
smaller rectangle on top of it, Revit Structure blends the 2 shapes together.

Sample base and top boundaries
for a blend.

Finished blend

NOTE If you want to dimension a solid blend after you create it, you can dimension from lines at the top of the
blend to lines at the base of the blend. You cannot dimension from lines at the base of the blend to lines at the
top of the blend.

To create a solid or void blend

1 In the Family Editor, on the Create tab ➤ Forms panel, do one of the following:

■ Click Solid drop-down ➤ Blend.

■ Click Void drop-down ➤ Blend.

NOTE If necessary, set the work plane before you sketch the blend. Click Create tab ➤ Work Plane
panel ➤ Set.
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2 On the Create Blend Base Boundary tab, use the sketching tools to sketch the base boundary of
the blend, for example sketch a square.

3 To specify the depth of the blend, do either of the following:

■ To specify a depth that is calculated from a default start point of 0, on the Options Bar, for
Depth, enter a value.

■ To specify a depth that is calculated from a start point other than 0, on the Create Blend
Base Boundary tab ➤ Element panel, click Blend Properties. Under Constraints, enter new
Second End and First End values.

NOTE If specified, Revit Structure does not retain the end point value during creation of the
blend. If you need to make multiple blends with the same end point, first sketch the blends, then
select them, and then apply the end point.

4 When finished with the base boundary, on the Create Blend Base Boundary tab ➤ Mode panel,
click Edit Top.

5 On the Create Blend Top Boundary tab, sketch a boundary for the top of the blend, for example
another square.

6 If necessary, edit the vertex connections to control the amount of twist in the blend:

■ On the Create Blend Top Boundary tab, click Mode panel ➤ Edit Vertices.

■ Vertex points become available on one of the blend sketches.

The dotted lines with blue open-dot controls are suggested connections. Each control is a
switch between adding and removing connections.

■ To display the vertex points on the other blend sketch, on the Edit Vertices tab ➤ Vertex
Connect panel, click Controls on Base or Controls on Top (whichever option is currently
unselected).

■ Click a control, and the line becomes a solid connection. A filled blue control displays on
the connection.
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■ Click a solid control to remove a connection; the line reverts to a dashed line with an open
dot control.

■ As you click the controls, some possible edges disappear and other ones appear.

■ On the Vertex Connect panel, click Twist Right or Twist Left to twist the selected blend
boundary in a clockwise or counter-clockwise direction.

7 Specify the blend properties:

■ On the Element panel, click Blend Properties.

■ To set the visibility of a solid blend, under Graphics, for Visibility/Graphics Overrides, click
Edit, and specify the visibility settings.

■ To apply a material to a solid blend by category, under Materials and Finishes, click in the

Material field, click  , and specify a material.

■ To assign a solid blend to a subcategory, under Identity Data, for Subcategory, select a
subcategory.

■ Click OK.

8 On the Blend panel, click Finish Blend.

9 To view the blend, open a 3D view.

10 To resize the blend in the 3D view, select and use grips to edit it.

Editing a Blend
1 In the drawing area, select the blend.

2 If you are in the project environment:

a On the Modify <Element> tab ➤ Family panel, click Edit Family.

b Click Yes to open the family for editing.

c In the Family Editor, select the blend in the drawing area again.

3 On the Options Bar, enter a value in the Depth text box to change depth of the blend.

4 On the Modify Blend tab ➤ Edit Blend panel, select an editing option:

■ Click Edit Top to edit the top boundary of the blend.

■ Click Edit Base to edit the base boundary of the blend.
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5 To edit other blend properties, on the Edit Top Boundary tab or Edit Base Boundary tab, click
Element panel ➤ Blend Properties, and change the visibility, material, or subcategory of the
blend.

6 To change the blend to a solid or a void, under Identity Data, for Solid/Void, select Solid or
Void.

7 Click OK.

8 On the Edit Top Boundary tab or Edit Base Boundary tab, click Mode panel ➤ Edit Vertices, and
edit the blend vertices.

9 On the Blend panel ➤ click Finish Blend.

Creating a Revolve
A revolve is a form that you create by revolving a shape around an axis. You can revolve the shape in a circle
or any fraction of a circle. If the axis touches the revolve shape, the result is a solid.

If you sketch away from the axis, the resulting geometry has a hole in it.

Use solid revolves to create family geometry like door and furniture knobs, columns, and dome roofs.

The following procedure is a general method for creating revolved geometry. Steps may vary depending on
your design intent.

To create a solid or void revolve

1 In the Family Editor, on the Create tab ➤ Forms panel, do one of the following:

■ Click Solid drop-down ➤ Revolve.

■ Click Void drop-down ➤ Revolve.

NOTE If necessary, set the work plane before you sketch the revolve. Click Create tab ➤ Work Plane
panel ➤ Set.

2 Place an axis of revolution:

■ On the Create Revolve tab ➤ Draw panel, click Axis Line.

■ Specify the start and endpoint of the axis at the desired orientation.

3 Use the sketching tools to sketch a shape to revolve around the axis:

■ On the Create Revolve tab ➤ Draw panel, click Boundary Lines.

■ To create a single revolve, sketch a closed loop.

■ To create more than one revolve, sketch multiple, non-intersecting, closed loops.

IMPORTANT If the axis touches the revolve shape, the result is a solid. If the axis does not touch the
revolve shape, the revolve will have a hole in it.

4 Change the properties of the revolve:

■ On the Create Revolve tab ➤ Element panel, click Revolve Properties.

■ To change the start and end points of the geometry to revolve, enter a new Start and End
Angle.

■ To set the visibility of a solid revolve, under Graphics, for Visibility/Graphics Overrides, click
Edit.
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■ To apply a material to a solid revolve by category, under Materials and Finishes, click in the

Material field, and click  to specify a material.

■ To assign a solid revolve to a subcategory, under Identity Data, for Subcategory, select a
subcategory.

■ Click OK.

5 On the Revolve panel, click Finish Revolve.

6 To view the revolve, open a 3D view.

7 To resize the revolve in the 3D view, select and use grips to edit it.

NOTE You cannot drag the start and end faces of a 360-degree revolve.

Editing a Revolve
1 In the drawing area, select the revolve.

2 If you are in the project environment:

a On the Modify <Element> tab ➤ Family panel, click Edit Family.

b Click Yes to open the family for editing.

c In the Family Editor, select the revolve in the drawing area again.

3 On the Modify Revolve tab ➤ Edit panel ➤ click Edit Sketch.

4 If desired, modify the revolve sketch.

5 To edit other revolve properties, on the Edit Revolve tab ➤ Element panel, click Revolve
Properties, and change the start and end points, visibility, material, or subcategory.

6 To change the revolve to a solid or a void, under Identity Data, for Solid/Void, select Solid or
Void.

7 Click OK.

8 On the Revolve panel, click Finish Revolve.

Creating a Sweep
A sweep is a tool for creating families that requires you to sketch or apply a profile (shape) and extrude that
profile along a path.

The following procedure is a general method for creating a sweep. Steps may vary depending on your design
intent.

To create a solid or void sweep

1 In the Family Editor, on the Create tab ➤ Forms panel, do one of the following.

■ Click Solid drop-down ➤ Sweep.

■ Click Void drop-down ➤ Sweep.

NOTE If necessary, set the work plane before you sketch the sweep. Click Create tab ➤ Work Plane
panel ➤ Set.
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2 Specify the sweep path:

■ To sketch a new path for the sweep, on the Create Sweep tab ➤ Mode panel, click Sketch
Path.
The path can either be a single closed or single open path. You cannot have multiple paths.
The path can be a combination of straight lines and curves, and it need not be planar.

■ To select an existing line for the sweep, on the Create Sweep tab ➤ Mode panel, click Pick
Path.
You can select edges of other solid geometry, such as extrusions or blends, or you can pick
existing sketch lines. Watch the status bar to know what you are picking. This method of
picking automatically locks the sketch lines to the geometry you are picking and allows you
to sketch the path in multiple work planes, hence allowing for a 3D path.

3 Sketch or pick the path, and then on the Path panel, click Finish Path.

4 Load or sketch a profile:

■ To load a profile:

a Click Modify Profile tab ➤ Edit panel, and select a profile from the Profile list.
If the profile you need is not already loaded in the project, click Modify Profile tab ➤ Edit
panel ➤ Load Profile to load the profile.

b On the Options Bar, use the X, Y, Angle, and Flip options to adjust the position of the
profile.
Enter values for X and Y to specify the offset for the profile.

Enter a value for Angle to specify the angle of the profile. The angle rotates the profile
around the profile origin. You can enter negative values to rotate in the opposite
direction.

Click Flip to flip the profile.

c Click Apply.

d Select the path, and zoom in to see the profile.

■ To sketch a profile:

a Click Modify Profile tab ➤ Edit panel, verify <By Sketch> is displayed, and then click
Edit Profile.

b If the Go To View dialog displays, select the view where you want to sketch the profile,
and click OK.
For example, if you sketched the path in a plan view, you would choose an elevation
view to sketch the profile. The profile sketch can be a single-closed loop or multiple
closed loops that do not intersect. Sketch the profile near the intersection of the profile
plane and the path.

c Sketch the profile. Profiles must be closed loops.

d On the Create Profile Sketch tab ➤ Profile panel, click Finish Profile.

5 Specify the sweep properties:

■ On the Create Sweep tab ➤ Element panel, click Sweep Properties.

■ To set the visibility of a solid sweep, under Graphics, for Visibility/Graphics Overrides, click
Edit, and specify the visibility settings.

■ To apply a material to a solid sweep by category, under Materials and Finishes, click in the

Material field, click  , and specify a material.
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■ To assign a solid sweep to a subcategory, under Identity Data, for Subcategory, select a
subcategory.

■ Click OK.

6 On the Sweep panel, click Finish Sweep.

Editing a Sweep
1 In the drawing area, select the sweep.

2 If you are in the project environment:

a On the Modify <Element> tab ➤ Family panel, click Edit Family.

b Click Yes to open the family for editing.

c In the Family Editor, select the sweep in the drawing area again.

3 On the Modify Sweep tab ➤ Form panel, click Edit Sweep.

4 To modify the sweep path:

■ On the Create Sweep tab ➤ Mode panel, click Sketch Path.

■ Use the tools on the Edit tab to modify the path.

■ On the Path panel, click Finish Path.

5 To modify the sweep profile:

■ On the Create Sweep tab ➤ Mode panel, click Select Profile.

■ On the Edit panel, use the tools that display to select a new sweep profile or change the
sweep profile location. You can edit the existing profile using the tools on the Modify Profile
tab.

6 To edit other sweep properties, on the Element panel, click Sweep Properties, and change the
visibility, material, segmentation, or subcategory of the sweep.

7 To change the sweep to a solid or a void, under Identity Data, for Solid/Void, select Solid or
Void.

8 Click OK.

9 On the Sweep panel, click Finish Sweep.

Sweep Tips
When creating a sweep with a tangent arc in the path, be sure the profile is small enough to sweep around
the arc without the resulting geometry intersecting itself. An error occurs if the geometry intersects.

If you create a sweep path by using the Pick Path tool, you can drag the end points of the path lines as you
are sketching it.
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Creating a Swept Blend
The Swept Blend tool allows you to create a blend that has 2 different profiles and then sweep it along a
path. The shape of a swept blend is determined by the 2D path you either sketch or pick and the 2 profiles
you either sketch or load.

The following procedure is a general method for creating a swept blend. Steps may vary depending on your
design intent.

To create a solid or void swept blend

1 In the Family Editor, on the Create tab ➤ Forms panel, do one of the following:

■ Click Solid drop-down ➤ Swept Blend.

■ Click Void drop-down ➤ Swept Blend.

2 Specify the path for the swept blend. Do one of the following on the Create Swept Blend
tab ➤ Mode panel:

■ Click Sketch Path to sketch a path for the swept blend.

■ Click Pick Path to pick an existing line for the swept blend.

NOTE If necessary, set the work plane before you sketch or pick the path for the swept blend. Click
Create tab ➤ Work Plane panel ➤ Set.

3 Sketch or pick the path, and then on the Path panel, click Finish Path.
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NOTE A swept blend path can only have one segment.

4 Load or sketch Profile 1.

The end point for Profile 1 on the swept blend path is highlighted.

■ To load a profile:

a Click Modify Profile tab ➤ Edit panel, and select a profile from the Profile drop-down.
If the profile you need is not already loaded in the project, click Load Profile to load
the profile.

b Zoom in to see the profile.

c Use the X, Y, Angle, and Flip options to adjust the position of the profile.
Enter values for X and Y to specify the offset for the profile.

Enter a value for Angle to specify the angle of the profile. The angle rotates the profile
around the profile origin. You can enter negative values to rotate in the opposite
direction.

Click Flip to flip the profile.

d Click Apply.

■ To sketch a profile:

a On the Edit panel, verify that <By Sketch> is selected and click Edit Profile.

b If the Go To View dialog displays, select the view where you want to sketch the profile,
and click OK.

c Use the tools on the Create Profile tab to sketch the profile. Profiles must be closed
loops.

d On the Profile panel, click Finish Profile.
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5 Click Swept Blend tab ➤ Mode panel ➤ Modify Profile 2.

6 Load or sketch Profile 2 using the steps above.

7 Optionally, edit the vertex connections. By editing vertex connections, you control the amount
of twist in the swept blend. You can edit vertex connections in plan or 3D views.

a On the Swept Blend tab ➤ Mode panel, click Edit Vertices.

b On the Edit Vertices tab ➤ Vertex Connect panel, select Controls on Base or Controls on
Top.

c In the drawing area, click the blue controls to move the vertex connections.

d On the Vertex Connect panel, click the Twist Right and Twist Left tools to twist the swept
blend.

8 Specify the swept blend properties:

■ On the Element panel, click Swept Blend Properties.

■ To set the visibility of a solid swept blend, under Graphics, for Visibility/Graphics Overrides,
click Edit, and specify the visibility settings.

■ To apply a material to a solid swept blend, under Materials and Finishes, click in the Material

field, click  , and specify a material.

■ To assign a solid swept blend to a subcategory, under Identity Data, for Subcategory, select
a subcategory.

■ Click OK.

9 When finished, click Swept Blend panel ➤ Finish Swept Blend.

Editing a Swept Blend
1 In the drawing area, select the swept blend.

2 If you are in the project environment:

a On the Modify Swept Blend tab ➤ Edit Swept Blend panel, click Edit Family.

b Click Yes to open the family for editing.

c In the Family Editor, select the swept blend in the drawing area again.

3 On the Modify Swept Blend tab ➤ Form panel, click Edit Swept Blend.

4 To edit the path:

a On the Create Swept Blend tab ➤ Mode panel, click Sketch Path.

b Use the tools on the Sketch Path tab to modify the path, and click Path panel ➤ Finish
Path.

5 To edit the profiles:

a On the Swept Blend tab ➤ Mode panel, click Modify Profile 1 or Modify Profile 2.

b On the Edit panel, select a different loaded profile from the drop-down list, or select <By
Sketch> from the list to sketch a new profile.

c If you selected <By Sketch>, click Edit Profile on the Edit panel.

d Sketch the profile and then click Profile panel ➤ Finish Profile.
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6 To edit other swept blend properties, click Swept Blend tab ➤ Element panel ➤ Swept Blend
Properties, and change the visibility, material, or subcategory of the sweep.

7 To change the swept blend to a solid or a void, under Identity Data, for Solid/Void, select Solid
or Void.

8 Click OK.

9 On the Swept Blend panel, click Finish Swept Blend.

Cut Geometry
With the Cut Geometry tool, you can pick and choose which geometry gets cut and which does not, regardless
of when you created the geometry.

1 In the Family Editor, create solid geometry; it can be a single primitive or some joined primitives.

2 Create a void through the solid geometry.

3 Create another solid geometry shape and join it to the existing geometry.

4 Click Modify tab ➤ Edit Geometry panel ➤ Cut drop-down ➤ Cut Geometry and select the void
you created.

Notice the cursor changes shape.

44 | Chapter 3   Loadable Families Overview



5 Select the geometry you created in Step 3.

Revit Structure cuts the selected geometry.

Uncut Geometry
1 In the Family Editor, click Modify tab ➤ Edit Geometry panel ➤ Cut drop-down ➤ Uncut

Geometry.

2 Select the void.

3 Select the appropriate solid primitives that you do not want to cut.

NOTE If you select all geometry to not be cut, then the void appears at all times in the view.
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Creating 2D Geometry
To create 2D family geometry, you use the Revit Structure Model and Symbolic lines tools that are available
in the Family Editor.

The Model Line tool on the Create tab ➤ Model panel lets you sketch two-dimensional geometry for when
you do not need to show solid geometry. For example, you could sketch door panels and hardware as 2D
rather than sketch solid extrusions. Model lines are always visible in 3D views. You can control their visibility
in plan and elevation views by selecting the lines and clicking Modify Lines tab ➤ Visibility panel ➤ Visibility
Settings.

The Symbolic Line tool on the Detail tab ➤ Detail panel lets you sketch lines that are meant for symbolic
purposes only. Symbolic lines are not part of the actual geometry of the family. Symbolic lines are visible
parallel to the view in which you sketch them.

You can control symbolic line visibility on cut instances. Select the symbolic line and click Modify Lines
tab ➤ Visibility panel ➤ Visibility Settings. Select Show only if instance is cut.

In the displayed dialog, you can also control the visibility of lines based on the detail level of the view. For
example, if you select Coarse, that means that when you load the family into a project and place it in a view
at the Coarse detail level, the symbolic lines are visible.

Creating and Using Profile Families
A profile family contains a 2-dimensional closed loop that you can load into a project and apply to certain
building elements. For example, you can sketch the profile loop for a railing and then use that shape on a
railing in your project.

When you define one profile family, you can reuse it multiple times on building elements in the project.
Loaded profiles display in the Project Browser under Families.

Create profile families using family templates supplied with Revit Structure. These templates are Profile.rft,
Profile-Rail.rft, Profile-Reveal.rft, Profile-Stair Nosing.rft, and Wall Sweep Profile.rft.

Creating a Profile Family
To create a profile family, open a new family, and sketch a profile using lines, dimensions, and reference
planes. After you save the profile family, you can load it and apply it to solid geometry in the project.

This procedure describes creating a generic profile shape that is available to multiple building elements in
the project. Your specific building and design intentions may differ.

To create a profile

1 Click  ➤ New ➤ Family.

2 In the New Family - Select Template File dialog, select a profile template, and click Open.

The Family Editor opens a plan view that includes 2 reference planes. There are no other views
available in which to sketch geometry.

3 If necessary, sketch reference planes for constraining the lines in the profile.

4 Click Create tab ➤ Detail panel ➤ Line, and sketch the profile loop.

For more information about the sketching tools, see Sketching in the Revit Structure 2010 Help.

5 If necessary, click Create tab ➤ Detail panel ➤ Detail Component to place a detail component
into the profile family.
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TIP You can change the sorting order of any detail components in the family by using the detail
component draw order tools. See Sorting Element Draw Order in the Revit Structure 2010 Help.

6 To specify the detail at which the profile family displays in the project, select any of the lines
of the profile sketch, and click Modify Lines tab ➤ Visibility panel ➤ Visibility Settings.

7 Select the desired detail levels (Fine, Medium, or Coarse), and click OK.

TIP You can specify the detail level for detail components using the same methods.

Next, define the profile usage.

8 Click Family Properties panel ➤ Category and Parameters.

9 In the Family Category and Parameters dialog, under Family Parameters, for Profile Usage, click
in the Value field, and select the profile type.

For example, if you are creating a mullion profile, select Mullion.

TIP This setting ensures that only relevant profiles are listed when using profiles within a project. For
example, when selecting a mullion profile, stair nosing profiles do not display.

10 Click OK.

11 Add any dimensions required.

Sample metal deck profile sketch

12 Save the family.

Loading a Profile Family into a Project
1 In a project file, click Insert tab ➤ Load from Library panel ➤ Load Family.

2 Navigate to the profile family file you created, select it, and click Open.

3 In the Project Browser, expand Families ➤ Profiles.

The family that you created and loaded displays and can be applied to building elements in the
project.
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Dimensioning Family Geometry
As you create the geometry of component families, you place dimensions to define the geometric relationships
that you want to control with parameters. By labeling the dimensions that you place, you create a parameter
that you can control.

To add dimensions, you can use the Dimension tools on the Family Editor Create tab, or you can turn on
automatic dimensions.

Automatic Sketch Dimensions
Revit Structure creates automatic dimensions to help control your design intent. These automatic dimensions
are not displayed by default.

To turn them on, select Automatic Sketch Dimensions on the Annotation Categories tab of the
Visibility/Graphic Overrides dialog. You can then modify the dimensions or create your own dimensions
using the Dimension tools. You can also lock dimensions to keep a distance constant. This is useful if you
plan to have several sizes of the family and want to keep certain dimensions constant while the family
changes size.

Effects of Automatic Dimensions on Your Geometry

When automatic sketch dimensions constrain geometry to reference planes, you may see some unexpected
behavior in your project. The automatic sketch dimensions are Revit Structure's way of solving how to grow
or shrink geometry based on changes in value of a family parameter.

For example, you have added a rectangular window to a fire door that has a labeled dimension for the width,
but you have not dimensioned the window.

You decide to change the width of the door, but you want the window width to stay the same. You expect
its position to remain unchanged; however, observe what happens when you increase the width of the door
using the Family Types tool.

In this example, the small extrusion is constrained to the centerline of the panel board and the right side
of the panel board, both of which are represented by reference planes. The small extrusion’s position remains
fixed relative to those reference planes.

Image legend:

1 Auto sketch dimension to right reference plane.

2 Auto sketch dimension to center reference plane.

To achieve the desired results, add locked dimensions.

Visibility of Automatic Sketch Dimensions in the Family Editor
Automatic sketch dimensions are turned off by default. They display if there is at least one labeled dimension
in the family.

Notice in the following image that there is a dimension added to the geometry, but the dimension has no
label.
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No automatic sketch dimensions are visible.

To turn on visibility of automatic sketch dimensions

1 While in sketch mode, click View tab ➤ Graphics panel ➤ Visibility and Appearance, or type
VG.

2 On the Annotation Categories tab of the Visibility/Graphic dialog, expand the Dimensions
category, and select Automatic Sketch Dimensions.

3 Click OK.

4 Place and label a dimension.

The automatic sketch dimensions display.

Revit Structure now knows where each line of this geometry exists with respect to reference planes or other
sketch lines.

As you add locked dimensions, they replace the automatic sketch dimensions, as shown.
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Dimensioning with Families
Families in Revit Structure are not parametric until you add labeled dimensions (parameters) to them.

Labeling dimensions
1 Highlight the dimension text.

2 Right-click the dimension, and click Edit Label.

3 Select a label name, or select <Add parameter...> and create a parameter.

Alternate procedure for labeling

1 Select the dimension text.

2 On the Options Bar, for Label, select a name, or create a new parameter.

3 If desired, select Leader to create a leader line for the dimension.

Tips for Creating Family Dimensions
■ You cannot type text as a label when you select a dimension. You can only select from a list of family

parameters that are of the correct type, or you can create a new parameter.
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■ Labeled dimensions become modifiable parameters for families. You can modify their values using the
Family Types dialog. When the family is loaded into a project, you can also modify the dimensions using
the Instance Properties dialog.

■ Values for labeled parameters can be calculated using formulas. You create the formulas in the Family
Types dialog. See Using Formulas for Numerical Parameters on page 54.

■ An array number can be a parameter for a family. After you create the array, you should select it and
then label it in order to create a parameter. You can then modify the parameter value and increase or
decrease the number of elements in the array. See Creating an Array in the Revit Structure 2010 Help.

Adding Family Parameters
You can create instance or type parameters for any family type. By adding parameters, you gain control over
the information contained in each family instance or type. You can create dynamic family types for increased
flexibility within the model.

Creating Parameters

To create parameters

1 In the Family Editor, on any tab, click Family Properties panel ➤ Types.

2 In the Family Types dialog, click New, and enter a name for the new type.

This creates a new family type that will be available in the Type Selector when you load it into
a project.

3 Under Parameters, click Add.

4 In the Parameter Properties dialog, under Parameter Type, select Family parameter.

5 Enter a name for the parameter.

6 Select a discipline.

7 For Type of Parameter, select the appropriate parameter type.

DescriptionName

Completely customizable. Can be used to collect unique data.Text

A value that is always expressed as an integer.Integer

Used to collect miscellaneous numeric data. Can be defined by a formula. Can also
have real numbers.

Number

Can be used to establish the length of an element or subcomponent. Can be defined
by a formula.

Length

Can be used to establish the area of an element or subcomponent. Formulas can
be used in this field.

Area

Can be used to establish the length of an element or subcomponent. Formulas can
be used in this field.

Volume

Can be used to establish the angle of an element or subcomponent. Formulas can
be used in this field.

Angle

Can be used to create parameters that define slope.Slope
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DescriptionName

Can be used to create currency parameters.Currency

Provides web link to user defined URL.URL

Establishes parameters in which a specific material can be assigned.Material

Used most often for instance properties when the parameter is defined with either
a Yes or No.

Yes/No

Used with nested components and allows you to swap components after the family
is loaded into a project.

Family Type

8 For Group parameter under, select a value.

After the family is loaded into a project, this value determines which group header the parameter
displays under in the Instance Properties dialog.

9 Select either Instance or Type. This defines whether the parameter is an Instance or Type
parameter.

10 Click OK.

NOTE To assign a material to a family element, save the family and load it into a project. Place the
family in the project and select it. On the Family Properties panel, click Types and set a value for the
material parameter.

Modifying Family Parameters
In the Family Types dialog, select the desired parameter, and click Modify. You can rename the parameter
and change whether it is a type or instance parameter. You can also replace it with a shared parameter.

Instance Parameters and Shape Handles
As you create families, you can specify labeled dimensions as instance parameters; the parameters are
modifiable when the family instance is placed in a project. Labeled dimensions specified as instance parameters
can also have shape handles that display when the family is loaded into a project.

Creating Instance Parameters
1 Sketch family geometry using Family Editor tools.

2 Create dimensions for the family geometry.

3 Label the dimensions. See Labeling Dimensions to Create Parameters on page 26.

4 Select the dimensions and, on the Options Bar, select Instance Parameter.

NOTE If you label dimensions by selecting a label on the Options Bar, you can select Instance
Parameter without re-selecting the dimensions.

5 Click Modify Dimension tab ➤ Family Properties panel ➤ Types.

In the Family Types dialog, notice the new instance parameter. The (default) label indicates the
value for the instance parameter when you place the family in a project. For example, if you
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create an instance parameter called length with a default value of 3000 mm, the family instance
will have a length of 3000 mm when placed in a project.

6 Save changes and load the family into a project. Select an instance of the family and click
Element panel ➤ Element Properties drop-down ➤ Instance Properties.

Notice that the labeled dimensions display as parameters in the Instance Parameters pane of
the Instance Properties dialog. You can change the values in the dialog.

Adding Shape Handles to a Component Family
You can add shape handles to a component family that display when the family is loaded into a project.
The shape handles let you resize the component in the project, instead of creating multiple types in the
Family Editor. See Controls and Shape Handles in the Revit Structure 2010 Help.

Example of a generic component in plan and 3D views with shape handles
added

To add shape handles to a component family, you must:

■ Add reference planes to the family.

■ Align the reference planes to the edge of the component where you want the shape handle to display.

■ Add a dimension to the reference planes.

■ Label the dimension as an instance parameter.

■ Save the family and load it into a project. When you select the component, shape handles display where
the reference planes are aligned and dimensioned.

To add shape handles:

1 While in the Family Editor, add reference planes parallel to where you want the shape handles
to display.

In the following image, a generic component with a simple extrusion is shown in plan view.
Reference planes have been added parallel to the left and right edges.
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2 Select each of the reference planes, and click Modify Reference Planes tab ➤ Element
panel ➤ Element Properties drop-down ➤ Instance Properties. Verify that the Is Reference
parameter is a value other than Not a Reference.

3 Align and lock the reference planes to the parallel edges of the component. When the family is
loaded into a project, the shape handles will display at this location.

Generic component family
with reference planes aligned
and locked to the extrusion
edges

4 Add a dimension between the reference planes that you aligned in the previous step.

5 Select the dimension.

6 On the Options Bar, for Label, select a label, or click Add Parameter and create a parameter for
the dimension.

See Adding Family Parameters on page 51.

7 On the Options Bar, select Instance Parameter.

NOTE When adding a parameter, you can select Instance for the type in the Parameter Properties
dialog.

8 Save changes and load the family into a project.

After the family is loaded into a project, select the component. Shape handles display and allow you to resize
the family without the need for creating new sizes in the Family Editor.

Using Formulas for Numerical Parameters
Formulas allow you to create parameters that depend on other parameters for their values. A simple example
would be a width parameter set to equal twice the height of an object. In practice, formulas can be used in
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many ways, both simple and sophisticated. Typical uses include embedding design relationships, relating a
number of instances to a variable length, and setting up angular relationships. For example, formulas can
be used to

■ Calculate area or volume of geometry

■ Create a clearance dimension parameter controlled by element size

■ Convert continuously variable values into integer values

■ Add shelves as the height of casework increases

■ Add diagonals in an open web joist as the length increases

Adding a Formula to a Parameter
1 In the Family Editor, lay out reference planes.

2 Add dimensions, as required.

3 Label the dimensions. See Labeling Dimensions to Create Parameters on page 26.

4 Add the geometry, and lock the geometry to the reference planes.

5 On the Family Properties panel, click Types.

6 In the Family Types dialog, in the Formula column next to the appropriate parameter, type the
formula for the parameter. For more information about entering formulas, see Valid Formula
Syntax and Abbreviations on page 55.

Valid Formula Syntax and Abbreviations
Formulas support the following arithmetic operations: addition, subtraction, multiplication, division,
exponentiation, logarithms, and square roots. Formulas also support the following trigonometric functions:
sine, cosine, tangent, arcsine, arccosine, and arctangent.

The valid formula abbreviations for arithmetic operations and trigonometric functions are

■ Addition— +

■ Subtraction— -

■ Multiplication—*

■ Division—/

■ Exponentiation—^: x^y, x raised to the power of y

■ Logarithm—log

■ Square root—sqrt: sqrt(16)

■ Sine—sin

■ Cosine—cos

■ Tangent—tan

■ Arcsine—asin

■ Arccosine—acos

■ Arctangent—atan

■ e raised to an x power—exp
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■ Absolute Value—abs

You can enter integers, decimals, and fractional values in formulas, using normal mathematical syntax, as
shown in the examples below:

■ Length = Height + Width + sqrt(Height*Width)

■ Length = Wall 1 (11000mm)+ Wall 2 (15000mm)

■ Area = Length (500mm) * Width (300mm)

■ Volume = Length (500mm) * Width (300mm) * Height (800 mm)

■ Width = 100m * cos(angle)

■ x = 2*abs(a) + abs(b/2)

■ ArrayNum = Length/Spacing

Parameter names in formulas are case sensitive. For example, if a parameter name begins with a capital letter,
such as Width, you must enter it in the formula with an initial capital letter. If you enter it in a formula
using lower-case letters instead, for example, width * 2, the software will not recognize the formula.

Conditional Statements in Formulas
You can use conditional statements in formulas to define actions in a family that depend on the state of
other parameters. With conditional statements, the software enters values for a parameter based on whether
a specified condition is satisfied. Conditional statements are useful in certain circumstances; however, they
make families more complex and should be used only when necessary.

For most type parameters, conditional statements are unnecessary because the type parameter itself is like
a conditional statement: If this is the type, then set this parameter to a specified value. Instance parameters
are a more productive place to use conditional statements, particularly when they are used to set a parameter
that does not vary continuously.

Syntax for Conditional Statements

A conditional statement uses this structure: IF (<condition>, <result-if-true>, <result-if-false>)

This means that the values entered for the parameter depend on whether the condition is satisfied (true) or
not satisfied (false). If the condition is true, the software returns the true value. If the condition is false, it
returns the false value.

Conditional statements can contain numeric values, numeric parameter names, and Yes/No parameters.
You can use the following comparisons in a condition: <, >, =. You can also use Boolean operators with a
conditional statement: AND, OR, NOT. Currently, <= and >= are not implemented. To express such a
comparison, you can use a logical NOT. For example, a<=b can be entered as NOT(a>b).

The following are sample formulas that use conditional statements.

Simple IF: =IF (Length < 3000mm, 200mm, 300mm)

IF with a text parameter: =IF (Length > 35', “String1”, “String2”)

IF with logical AND: =IF ( AND (x = 1 , y = 2), 8 , 3 )

IF with logical OR: =IF ( OR ( A = 1 , B = 3 ) , 8 , 3 )

Embedded IF statements: =IF ( Length < 35' , 2' 6" , IF ( Length < 45' , 3' , IF ( Length < 55' , 5' , 8' ) ) )

IF with Yes/No condition: =Length > 40 (Note that both the condition and the results are implied.)
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Examples of Conditional Statement Usage

Typical uses for conditional statements in formulas include calculating array values and controlling an
element’s visibility based on a parameter value. For example, you can use conditional statements to

■ Prevent an array parameter from taking a value less than 2.
In Revit Structure, arrays can only have an integer value of 2 or greater. In some situations, it may be
useful to create a conditional formula that maintains an array parameter of 2 even if the calculated value
is 1 or 0. With such a formula, if the calculated array value is 2 or greater, the formula retains the value.
However, if the calculated value is 1 or 0, the formula changes the value to 2.

Formula: Array number = IF (Arrayparam < 2, 2, Arrayparam)

■ Make muntins visible only when the number of window lights is greater than 1.
For example, if you have a Lights parameter that you want to use to control the visibility of muntin
geometry, you can create a Yes/No parameter like MuntinVis, and assign it to the Visible parameter in
the Instance Properties dialog of the muntin geometry. Because the MuntinVis parameter is a Yes/No (or
Boolean) operation, both the condition (IF) and the results are implied. In this example, when the
condition is met (true), the MuntinVis parameter value is selected, and the muntin geometry is visible.
Conversely, when the condition is not met (false), the MuntinVis parameter is cleared, and the muntin
geometry is not visible.

Formula: MuntinVis = Lights > 1

Duplicating Parameterized Elements
When creating a component in the Family Editor, you often need to create identical elements that are
controlled by the same parameters, such as labelled dimensions or visibility parameters.

If you copy, array, or group a parameterized element, the parameters that control that element are also
copied.

In the example shown below, a generic family was created with 2 extrusions. The bottoms of both extrusions
are aligned to the horizontal reference plane. The height of the large extrusion is controlled by the labelled
dimension H. The height of the smaller extrusion is controlled by the labelled dimension (H/2). In the
Family Types dialog, a formula was added to the (H/2) parameter to make it equal to Height/2. In addition,
a visibility parameter was created and applied to the smaller extrusion, which has a split and painted face.

Elements controlled by parameters (labelled dimensions in this case)

Continuing with the example shown above, to create a series of elements identical to the sub-height element,
you can copy, array, or mirror the element, and the associated parameters are copied with it. In the image
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below, you can see that the smaller element was arrayed and the labelled dimension, painted face, and
visibility parameters are applied to each arrayed element.

Array of parameterized elements

In the Family Types dialog, if the Height value in this example is changed from 6 to 8, notice that the arrayed
elements adjust to the new values.

Arrayed elements adapt to changed parameter values

Assigning Family Geometry to Subcategories
You can assign different pieces of family geometry to subcategories within the family category. A subcategory
controls the line weight, line color, line pattern, and material of the geometry assigned to it, independent
of the family category settings. By assigning portions of the family geometry to different subcategories, you
can display the portions with different line weights, line colors, line patterns, and material assignments.

If you haven’t created subcategories or the family does not contain them by default, you can create them
at any time. See Creating Family Subcategories on page 20.
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To assign family geometry to a subcategory

1 In the Family Editor, select the family geometry that you want to assign to the subcategory.

2 Click Element panel ➤ Element Properties drop-down ➤ Instance Properties.

3 In the Instance Properties dialog, for Subcategory, select a subcategory.

4 Click OK.

Managing the Family Visibility and Detail Level
Visibility of a family determines in which view the family displays and what it looks like in that view.
Typically, when an element is created by a family, the geometry of the element will change, depending on
the current view. In a plan view, you may want to see a 2D representation of the element. In a 3D or elevation
view, you may want a fully detailed 3D representation of the element. You have the flexibility to display
different levels of geometry.

Detail Level determines the visibility of elements at different levels of detail. You control the detail level in
a project view with the Detail Level option on the View Control Bar.

You can set the visibility and detail level of any 2D and 3D geometry in the family before or after you create
it.

1 Do either of the following:

■ To set the visibility before you sketch the geometry, click the tool that you want to use to
create the geometry, and on the Visibility panel, click Visibility Settings.

■ If you have already created the geometry, select it, and click Visibility Settings. The name of
the panel this tool appears on varies depending on the type of geometry selected.

2 In the Family Element Visibility Settings dialog, select the views in which you want the geometry
to display:

■ Plan/RCP

■ Front/Back

■ Left/Right

NOTE All geometry automatically displays in 3D views.

3 If desired, select When cut in Plan/RCP (if category permits).

If you select this option, the geometry appears cut if it is intersected by the cut plane of the
view. If the element is cut by a section view, it also shows if you select this option.

4 Select the detail levels at which you want the geometry to display in a project:

■ Coarse

■ Medium

■ Fine

Detail levels are dependent upon view scale.

NOTE The Family Element Visibility Settings dialog is different for families of profiles and detail
components. For these families, you can set only the detail level.

5 Click OK.
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TIP You can set family elements to be visible or not visible in the project by associating the Visible
parameter of solid geometry tools with a family parameter for that element. The Visible parameter
is available for solid and void geometry tools (blends, sweeps, swept blends, revolves, and extrusions).
This lets you create one family type with optionally visible geometry on it. Note that the family
geometry still exists in the project, it is just invisible. For example, it may still be involved when you
join geometry in the project.

6 If you set the visibility before you created the geometry, create the geometry.

Adding a Website Link to a Family
You can add a website link to the Type or Instance properties of a family in both the Family Editor and in
the project environment. Selecting the URL opens the default web browser to the selected location.

Testing a Family in a Project
After you have finished a family, load it in at least one project, and create elements with the family types
to ensure it works correctly. Make sure you select a test project that contains any geometry with which the
family must interact.

BEST PRACTICE  Until you successfully test the family, do not save it in a library where it is accessible to others.

To test a family in a project

1 Open a test project.

NOTE Imperial and metric testing projects are available in the Training Files folder. Click 
 ➤ Open ➤ Project, click Training Files in the left pane of the Open dialog, and open Imperial or
Metric. Open Imperial_ Family_Testing_Template.rvt or Metric_Family_Testing_Template.rvt.

2 To load the family in the project, do either of the following:

■ In the family, click Create tab ➤ Family Editor panel ➤ Load into Project.

■ In the project, click Insert tab ➤ Load from Library panel ➤ Load Family, navigate to the
location of the family, select it, and click Open.

3 In the project, click the Home tab, and then click the appropriate tool to begin creating an
element from one of the new family types.

4 On the Element panel, select a type from the Type Selector drop-down.

5 Add the element to the project.

If the element is host-based, place it in a host element.

6 In the current view, test the element:

■ On the View Control Bar, change the Detail Level and/or Model Graphics style to ensure
that visibility settings work correctly.

■ Change the scale to resize the element.

■ Click View tab ➤ Graphics panel ➤ Visibility & Graphics, and change the visibility for the
element by category and, if applicable, by subcategories.

■ Select the element, right-click, and click Element Properties.
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■ In the Instance Properties dialog, change any of the instance parameters, and click OK to
view and verify the changes.

■ If the family contains multiple types, select the element, and on the Modify <element>
tab ➤ Element panel, select a different family type from the Type Selector drop-down.

7 Open additional project views, and repeat step 6.

8 If the family contains more than one type, repeat steps 3-6 to test other types in the family.

9 If you find any errors in the family, edit the family, and retest it in a project.

10 When you finish testing the family, save it in the imperial or metric Revit Structure library or
in another location of your choice.

Advanced Loadable Family Techniques
After you understand the basics of creating parametric families, there are more complex techniques that you
can use when you create families:

■ Nesting and sharing families to combine the geometry of 2 or more families

■ Linking family parameters

■ Creating face- and workplane-based families

Nesting and Sharing Component Families
You can nest (insert) families within other families to create new families that contain the combined family
geometry.

Whether you share families before you nest them determines the behavior of the nested geometry in elements
that you create with the family.

■ If you nest a family that is not shared, components created by the nested family act with the rest of the
element as a single unit. You cannot select (edit), tag, or schedule the components separately.

■ If you nest a shared family, you can select, tag, and schedule the components separately.

Nesting Restrictions

There are certain restrictions regarding the type of families that you can load and nest in other families:

■ Only annotation families can be loaded into other annotations.

■ Only detail families and generic annotations can be loaded into details.

■ Model families, details, generic annotations, section heads, level heads, and grid heads can be loaded
into model families.

Nesting Families with Interchangeable Components

By applying a family type parameter to a nested component, you can create families with interchangeable
subcomponents. After you load and create an element with the nested family, you can swap components
at any time.
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Creating a Family with Nested Components
To nest families in another family, create or open a host (base) family, and then load and insert instances
of one or more family types into it. The base family can be a new (empty) family or an existing family.

To create a family with nested components

1 Create or open a family into which you want to nest a family.

2 In the Family Editor, click Insert tab ➤ Load from Library panel ➤ Load Family.

3 Select any families that you want to nest, and click Open.

4 Click Home tab ➤ Build panel ➤ Family drop-down ➤ Place a Family.

5 On the Type Selector panel drop-down, choose the component type that you want to nest.

6 Click in the drawing area to place the nested component in the family.

7 If necessary, repeat steps 4-6 to nest components in the family.

8 Save the family.

Creating a Family with Nested and Shared Components
To create a family with nested and shared components, share the families before you nest them in a host
family. The host family does not need to be a shared family.

When you create a nested family of shared components, the first decision you need to make is in what
category the host family will belong. This decision has many downstream implications for tagging, scheduling,
and ODBC information, as described in the example below.

To share a family before nesting it

1 Open a family to be shared, and click Manage tab ➤ Family Properties panel ➤ Category and
Parameters.

IMPORTANT Annotation, profile, and in-place families cannot be shared families.

2 In the Family Category and Parameters dialog, under Family Parameters, select Shared.

Although you can set most families as shared families, it only becomes relevant when the family
is nested into another family and loaded into a project.

3 Click OK.

4 Save and close the family.

To nest shared families in a host family

1 Open the host family or start a new family.

2 Open the families that you want to nest, and share them.

3 Load and place a nested component within the host family.

4 Repeat this process for each nested component.

5 Save the family.
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Loading Families with Shared Components into a Project
You load families that contain nested components or nested and shared components into a project using
the same methods as any other family. When you load a family comprised of nested components or nested
and shared components into a project, the following rules apply:

■ The host family, along with all nested and shared components, is loaded into the project. Each nested
component is available within the Project Browser under its respective family category.

■ A nested family can exist within a project and be shared by more than one host family.

■ When loading shared families, if a version of one of the families already exists within the project, you
have the option to use the version from the project or from the family you are loading.

IMPORTANT After a shared family is loaded into a project, you cannot reload an unshared version of the same
family and overwrite it. You must delete the family and reload it.

To load families with shared components into a project

1 Open the project into which you want to load the family.

2 Click Insert tab ➤ Load from Library panel ➤ Load Family.

3 In the Load Family dialog, select the family to load, and click Open.

4 Add instances of the family to your projects.

Working with Shared Components in a Project
A family that contains nested and shared families works as any other family within a project. However, you
can press Tab to toggle to the nested and shared components.

If you select a nested instance, you can do the following:

■ Click Modify <Element> tab ➤ Element panel ➤ Element Properties drop-down ➤ Instance Properties.
In the Instance Properties dialog, modify some parameters, such as Mark and Comments.

■ Modify type properties. When you do this, all instances of that type also update to reflect the changes.

If you select a nested instance, you cannot do the following:

■ Select and delete a nested instance.

■ Mirror, copy, move, or array a nested instance.
If you do this, the entire host family adapts, not just the nested instance.

■ Modify the position, the size, or shape of a nested instance.

Scheduling Shared Components
To create a schedule containing shared families, you use the same method as any other schedule. See Schedule
Views in the Revit Structure 2010 Help.

When you nest and share families, you can schedule shared families as individual instances. A family
comprised of shared and nested families allows each instance of a nested family to schedule separately.
Within the schedule, you can renumber each instance of a nested family.

If a nested family contains multiple categories, each instance of a nested family displays in its respective
schedule and all components will display on a multi-category schedule.

Advanced Loadable Family Techniques | 63



In contrast, in a family where no nested families are shared, instances of the nested families schedule only
as one instance.

Creating a Nested Family with Interchangeable Components
You can create families that feature interchangeable nested components when added to your projects. To
control the type of family within a nested family, you create a family type parameter that can be either an
instance or type parameter. After you label a nested component as a family type parameter, subsequently
loaded families of the same type automatically become interchangeable without any further work.

If you need the nested family components to tag and schedule individually, make sure each family that you
load into the host family is shared.

1 Open a family or start a new one.

2 Load the components that you want to nest within the family. For example, if you are in a door
family, load several transom types.

3 Click Create tab ➤ Model panel ➤ Component, and select an element from the Type Selector
drop-down.

4 Click in the drawing area to place the first component at its desired location.

5 Select the nested component.

6 On the Options Bar, for Label, select Add Parameter.

NOTE When adding a parameter in the Family Types dialog, click Add Parameter, select Family Type
as the Category, and select the category from the Select Category dialog. When you add the parameter
using the Options Bar, the parameter is automatically assigned to Family Type and the respective
family category is assigned.

7 In the Parameter Properties dialog, under Parameter Type, select Family Parameter.

8 Under Parameter Data, enter a name for the parameter, and select either Instance or Type
parameter.

9 Select a value for Group parameter under.

This designates under which heading the parameter displays in the Instance (or Type) Properties
dialog.

10 Click OK.

11 Save the file and load it into a project.

12 Add the component to the building model, select it, and click Modify <element> tab ➤ Element
panel ➤ Element Properties drop-down ➤ Instance (or Type) Properties.

13 Locate the family type parameter, and select a different component from the list.

Controlling the Visibility of Families with Nested and Shared Components
You can control the visibility of nested family instances in the host family. See Managing the Family Visibility
and Detail Level on page 59.

1 In the host family, select the nested family.

2 Click Modify <element> tab ➤ Visibility panel ➤ Visibility Settings.

3 In the Family Element Visibility Settings dialog, specify the View Specific Display and Detail
Level settings.

NOTE In nested families, you cannot specify the visibility option for When cut in Plan/RCP.
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4 Click OK.

Linking Family Parameters
By linking family parameters, you can control the parameters of families nested inside host families from
within a project view. You can control either instance or type parameters.

To link parameters, they have to be the same type. For example, link a text parameter in the host family to
a text parameter in the nested family.

You can link a host-family parameter to more than one nested-family parameter of the same type. Also, you
can link this parameter to multiple nested families.

Creating Family Parameter Links
1 Create a family with instance parameters or type parameters of the available types.

2 Save the family and load it into a host family.

3 With the new family open, click Create tab ➤ Model panel ➤ Component drop-down ➤ Place
a Component, and place as many instances of the loaded family as desired.

4 Click Manage tab ➤ Family Properties panel ➤ Types.

5 In the Family Types dialog, under Parameters, click Add.

6 Follow the steps for creating a new parameter of the same type as the parameter you want to
control in the nested family.

7 Click OK to close the Family Types dialog.

8 Select an instance of the loaded family in the host family, and click Modify <Element>
tab ➤ Element panel ➤ Element Properties drop-down ➤ Instance Properties or Type Properties.

For instance properties and type properties, there is a column that has an equal sign (=) in the
column heading. Gray buttons next to certain parameters indicate that they can be linked to
other parameters.

9 Click the button next to a parameter that is of the same type as the one you created in Step 6.

For example, if you created a text parameter, you must select a text parameter here.

10 In the dialog that appears, select the parameter you created in Step 6 to associate it with the
current parameter, and click OK.

NOTE When you associate 2 parameters, an equal sign appears on the button: 

11 Click OK to close properties dialog.

12 Continue creating the host family, and save it.

13 Load the family into a project, and place a few instances of it.

14 Select an instance of the family and click Modify <Element> tab ➤ Element panel ➤ Element
Properties drop-down ➤ Instance Properties or Type Properties.

15 Locate the type or instance property you created.

16 Set it to the desired value and click OK.

The nested family changes according to the value you entered.
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Creating Parameter Links for Model Text
If you place model text into a family, it acts like a nested family. You can create parameters in the host
family to control the text and depth of the model text in the project.

To control text

1 To place some model text in the host family, click Create tab ➤ Model panel ➤ Model Text, and
then type the text in the Edit Text dialog.

2 On any tab, click Family Properties panel ➤ Types and add a family parameter that is of type
text. This will be the parameter that controls the text of the model text in the project.

3 In the Family Types dialog, enter some text in the Value field for the new parameter. For example,
if you created a parameter called Mtext, you might enter default.

NOTE Do not leave the Value field empty. If you do, Revit Structure issues a warning.

4 Click OK.

5 Select an instance of model text in the family, and click Modify Model Text tab ➤ Element
panel ➤ Element Properties drop-down ➤ Instance Properties.

6 In the Instance Properties dialog, for Text, click  .

7 In the Associate Family Parameter dialog, select the parameter you created to link to the model
text parameter.

8 Click OK twice.

9 Continue creating the host family and save it.

10 Load that family into a project and place a few instances of it.

11 Select an instance of the family and click Modify <element> tab ➤ Element panel ➤ Element
Properties drop-down ➤ Instance Properties.

12 Edit the model text parameter.

The model text updates to the new value. If you created an instance parameter, just the one
instance changes. If you created a type parameter, all current and future instances of the model
text change.

To control depth

Controlling model text depth is similar to controlling text, except that you create a family parameter that
is of type length. Follow the above procedure to link parameters for model text depth.

Loading Generic Annotations into Model Families
You can nest generic annotation families inside host model families, so that the annotations appear in the
project. This is useful if you want to include a label with a model family and display that label in the project.

Generic annotations hosted by model families scale with the view when they are loaded into the project.
When you place these generic annotations on a sheet, they display at the same size, regardless of view scale.
For example, a 3/32'' text label in a model family always prints at that size on a sheet, even if that label
appears on the sheet in a view with a 1/8" = 1'0" scale or a view with a 1/4'' = 1'0'' scale.

You can also control the visibility of generic annotations in the project separately from the host model
family.
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Adding a Generic Annotation
You can create a generic annotation family or load one from the available annotation families in the Revit
Structure library. This procedure uses an existing annotation family.

NOTE Though this procedure uses specific family files, the steps are common to any generic annotation you may
want to add to a model family.

1 Click  ➤ Open ➤ Family.

2 Open the microwave.rfa family from the Specialty Equipment\Domestic  folder in the Imperial
library. The microwave from the Metric library is in the same folder and is called
M_microwave.rfa.

3 Click Insert tab ➤ Load From Library panel ➤ Load Family.

4 . Navigate to the Annotations folder, select M_Label Annotation.rfa, and click Open.

5 Open a floor plan view in the file.

You can place a generic annotation in plan only.

6 Click Detail tab ➤ Detail panel ➤ Symbol, and place an instance of the label at the intersection
of the 2 reference planes in the center of the microwave.

Label snapping to intersection of
reference planes

Next you associate this label with a parameter in the host family.

7 Click Place Symbol tab ➤ Family Properties panel ➤ Types.

8 In the Family Types dialog, under Parameters, click Add.

9 In the Parameter Properties dialog, under Parameter Type, select Family parameter.

10 Under Parameter Data, for Name, type Label.

11 For Type of Parameter, select Text.

This parameter will be stored by type.

12 Click OK twice.

13 Select the label instance you placed on the  panelboard, and click Modify Generic Annotations
tab ➤ Element panel ➤ Element Properties drop-down ➤ Type Properties.

14 Locate the Label parameter.

15 In the row for the Label parameter, click the button under the equal sign (=) column.
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16 In the Associate Family Parameter dialog, select the parameter Label. This is the parameter you
created in steps 6-10.

17 Click OK twice.

18 If desired, you can set at which detail level the label appears in a project. Access the instance
properties for the annotation. Next to the Visibility/Graphics Overrides instance parameter,
click Edit, and then select coarse, medium, or fine. If you leave a particular detail level unselected,
the label will not show in a project view set at that detail level.

19 Save the family and load it into your project.

20 Open a plan view, and click Home tab ➤ Build panel ➤ Component.

21 Select the microwave from the Type Selector drop-down, and place an instance in the project.

22 Select the microwave, and click Modify Specialty Equipment tab ➤ Element panel ➤ Element
Properties drop-down ➤ Type Properties.

23 In the Type Properties dialog, for Label, enter MW.

24 Click OK.

The microwave displays with the specified label in the view.

25 If desired, change the detail level of the view to change the visibility of the label.

See Managing the Family Visibility and Detail Level on page 59.

NOTE  You can also change the visibility of the label by turning off Generic Annotations on the
Annotation Categories tab of the Visibility/Graphics dialog.

Creating Work Plane-based and Face-based Families
You can create a family that is hosted by the active work plane. This can be very useful both in a project
environment and within a nested family, when it’s necessary for a nested sub-component to reside on a
particular plane. You can make any non-hosted family a work plane-based family. For example, a generic
component, a furniture component, and a site component can all be work plane-based families because they
are not required to be hosted by another component. Doors and windows cannot be work plane-based
because they are wall-hosted components.
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Example of generic component family nesting a work plane-based component. On the
left, the work plane is selected; on the right, the work plane-based component was
added.

Another way to create components that can be placed with any orientation is to use face-based families. A
face-based family must be created from the Generic Model face based.rft template. A face-based component
can be placed on any surface, including walls, floors, roofs, stairs, reference planes, and other components.
If the family contains a void that cuts the host, the component will cut its host, only if the host is a wall,
floor, roof, or ceiling. When a component with a void is placed on any other host, it will not cut.

Creating a Work Plane-based Family
1 Open or create a non-hosted family.

NOTE Only non-hosted components can become work plane-based families.

2 In the Family Editor, on any tab, click Family Properties panel ➤ Category and Parameters.

3 In the Family Category and Parameters dialog, under Family Parameters, select Work Plane-Based.

4 Click OK.

NOTE You can make a family both work plane-based and always vertical. Examples of both are shown
below.

In the nested family below, the rectangular extrusion is a work plane-based component.
On the left, the extrusion is work plane-based but not always vertical. On the right,
the same extrusion was reloaded into the family after designating it work plane-based
and always vertical.
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Creating Vertical Families
The option to create vertical or non-vertical families pertains only to families hosted by walls, floors, ceilings,
roofs, and site surfaces. You can specify a family component, such as or a , to Always Vertical; after it is
loaded into a project, the component remains vertical regardless of the slope of the host. In the case of a ,
you can specify the Always Vertical option to No, which lets the adapt to the slope of the host.

NOTE The Always Vertical parameter does not apply to families created in non host-based templates.

To set the Always Vertical parameter for a family

1 In the Family Editor, on any tab, click Family Properties panel ➤ Category and Parameters.

2 In the Family Category and Parameters dialog, under Family Parameters, select Always Vertical.

3 Click OK.

Creating a Type Catalog
A type catalog is an external text file (TXT) that contains the parameters and their values that create the
different types in a specific family.

Following is a sample type catalog TXT file:

,Manufacturer##other##,Length##length##centimeters,Width##length##centi

meters,Height##length##centimeters

MA36x30,Revit,36.5,2.75,30

MA40x24,Revit,40.5,3.25,24

When loading the corresponding family, you would see the following type catalog:

HeightWidthLengthManufac-
turer

Type

30cm2.75cm36.5cmRevitMA36x30

24cm3.25cm40.5cmRevitMA40x24

There are several ways to create a comma-delimited .txt file. You can type it in a text editor such as Notepad,
or you can use database or spreadsheet software to automate the process.

You can export your project to a database using ODBC, and then download the element type tables in
comma-delimited format. See Exporting to ODBC in the Revit Structure 2010 Help.

As you create the type catalog, follow these rules:

■ Save the type catalog file name with a .txt extension; the file must have the same name and same directory
path as the Revit Structure family (for example, Connections/gusset2a.rfa and Connections/gusset2a.txt).

■ Use the left column to list types.

■ Use the top row of the file for parameter declaration. Format is columnname##type##unit.

■ Use decimals.

■ Parameter names are case sensitive.

■ You can use single or double quotes. If you are using double quotes, you need to enter "" for Revit Structure
to understand it as double quotes.

■ Valid unit types are length, area, volume, angle, force, and linear force.
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■ Valid units: Valid units and suffixes:

■ You can enter a value for parameters of type Family Type. To declare the Family Type parameter in the
parameter declaration, you would enter column-name##other##. The column name is the same as the
Family Type parameter name. In the type catalog file, enter values as Family Name : Family Type. Be sure
there are spaces before and after the colon. For example, a family file called Linear-Stiffener-Angle45.rfa
with a type called 4x4x5/8 would be entered as Linear-Stiffener-Angle45 : 4x4x5/8. If the family file has
only one type and it is the same name as the family, you do not need to include the Family Name.

■ Revit Structure applies project unit settings to type catalogs when you load a family.

Deleting Unused Families and Types
You can delete families or unused family types from your projects and templates using either of 2 methods:
you can select and delete the families and types in the Project Browser, or you can run the Purge Unused
tool.

Select and delete families and types when you have only a few families or types that you need to delete. Use
the Purge Unused tool when you need to “clean up” your projects. Removing all of the unused families and
types usually decreases the project file size.

Method 1: Selecting and deleting families and types in the Project Browser

1 In the Project Browser, expand Families.

2 Expand the category that contains the family or type that you want to delete.

3 If you want to delete a family type, expand the family.

4 Select the family or type that you want to delete.

TIP To select more than one family or type, press and hold Ctrl while selecting.

5 Do either of the following:

■ Right-click, and click Delete.

■ Press Delete.

The family or type is deleted from the project or template.

If you are deleting a family or type from a project, and there is one or more instances of a type
in the project, a warning displays.

6 In the alert dialog:

■ Click OK to delete any instances of the type.

■ Click Cancel, change the type, and repeat the previous step.

Method 2: Using the Purge Unused command

7 Click Manage tab ➤ Project Settings panel ➤ Purge Unused.

The Purge unused dialog lists all of the families and family types that you can unload from the
project, including system and in-place families. By default, all unused families are selected for
purging.

IMPORTANT If the project is workset-enabled, all worksets must be open to use this command.

8 Do either of the following:

■ To purge all unused family types, click OK.
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■ To purge only the types that you select, click Check None, expand the families and subfamilies
that contain the types that you want to purge, select the types, and click OK.
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Revit Structure Families
Tutorials
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Creating a Reinforcement
Family

In this lesson, you create a new 2-dimensional (2D) custom rebar shape that supports overlapping reinforcement. After
you create the layout, you add the shape to the rebar shape browser.

You also learn how to constrain the rebar layout by adding labeled dimensions (parameters) to specify values for the rebar
height, width, and overlap length.

Skills used in this lesson:

■ Create a 2D rebar family type

■ Draw the new rebar shape

■ Add dimensions to the layout

■ Create parameter labels to control the rebar dimensions

■ Load the new shape into an open project

Creating a Custom Reinforcement Layout
In this exercise, you create a 2D reinforcement shape for overlapping rebar. You use reference planes provided
with the standard rebar template to draw the new shape.

4
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Training File

■ Click  ➤  ➤ Open ➤ Project.

■ In the left pane of the Open dialog, click Training Files, and open Metric\Custom_Reinf_rst_m.rvt.

Create a new 2-dimensional (2D) rebar family

Begin by opening an existing 2D template that includes both horizontal and vertical reference planes that
are used as a guide to draw the new family.

1 Click  ➤ New ➤ Family.

2 In the left pane of the Open dialog, click Training Files, and open Metric\Metric 2D Rebar Shape
Template.rft.

Sketch the rebar

You use the basic drawing tools provided with Revit Structure to draw the new shape for the overlapping
rebar. The shape includes both an inside and outside loop and basically forms a square around the reference
planes.

3 Click Rebar Lines panel ➤  (Line).

4 Draw the overlapping rebar as one continuous line, as follows:

■ Click to the right of the vertical reference plane, and draw a horizontal line to create the top
surface of the rebar.

■ Click and draw a vertical line to create the inside loop.
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■ Click and draw a second horizontal line to create the bottom of the rebar.

■ Click and draw a second vertical line to create the outside loop.

■ Click and draw a horizontal line to complete the rebar sketch.
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5 Click Selection panel ➤ Modify.

Place dimensions

You add dimensions to the new shape which define the length, height, and width of the rebar. These
dimensions are used to control the parametric relationship of each element.

6 Click Dimension panel ➤ Aligned.

7 Place dimensions on the rebar sketch as shown.

Make sure that you snap to the reference plane when placing the dimensions.

8 Press Esc twice.

Create parameter labels

You label the dimensions to create specific parameters for the shape. The rebar shape is not considered
parametric until you add these labeled dimensions.

9 Select the upper horizontal rebar dimension as shown.
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10 On the Options Bar, for Label, select B.

11 Select the inside vertical rebar dimension as shown.

12 On the Options Bar, for Label, select C.

13 Select the bottom horizontal rebar dimension as shown.
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14 On the Options Bar, for Label, select D.

15 Select the outside vertical rebar dimension as shown.

16 On the Options Bar, for Label, select C.

17 Select the inner horizontal rebar dimension as shown.
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18 On the Options Bar, for Label, select B.

Save the new profile

19 Click  ➤ Save As ➤ Family.

20 Navigate to a folder of your choice, in the Save As dialog, for File name, enter Square, and click
Save.

Load the overlapping rebar into the open project

21 Click View tab ➤ Rebar Shape Editor panel ➤ Load into Project.

The new overlapping rebar family is now loaded into the project.

22 Press Esc twice.

Launch the rebar shape browser

Revit Structure 2010 provides a library of rebar shapes that define the layout of the rebar type instance in
the project. The shapes are displayed in a Rebar Shape Browser that displays when you select the rebar tool.

23 In the Project Browser, under Sections (Building Section), double-click Section 2.

24 Zoom in on the beam on level 02 - Floor.

25 Select the concrete beam.

26 Click Reinforcement panel ➤ Rebar drop-down ➤ Place Rebar Parallel to Work Plane.

The Rebar Shape Browser launches, positioned in the right-side of the drawing area. This browser
provides multiple rebar shape types that can be placed within the specified host. The active
rebar shape is highlighted, and corresponds to the shape specified on the Options bar.
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NOTE You can launch or close the Rebar Shape Browser by clicking  on the Options Bar.

Place rebar parallel to the beam

27 Click the Rebar Shape Browser, scroll down the list of available shapes, and select Rebar Shape:
Square.

28 Hover over the beam.

Notice that the rebar shape is positioned over the beam.

82 | Chapter 4   Creating a Reinforcement Family



29 Click to place the rebar.

30 Click Esc.

Modify rebar layout

31 Select the rebar.

Notice that the rebar shape handles appear.

32 Select one of the shape handles and change the length of the rebar overlap position and shape
as shown.
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33 Press Esc.

34 Close the file with or without saving it.

You have completed this lesson on Creating a Reinforcement Family.
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Creating a Custom Beam
Type

In this lesson, you create a custom beam type by modifying the construction properties and dimensions of an existing
castellated beam. These changes are then applied to additional beams in the project.

Skills used in this lesson:

■ Create a beam type

■ Change the size of the beam openings

■ Apply the new beam type

Customizing a Castellated Beam
In this exercise, you create a custom beam type by changing the dimensions for the openings in a standard
castellated beam.

5

85



Training File

■ Click  ➤ Open ➤ Project.

■ In the left pane of the Open dialog, click Training Files, and open Metric\Custom_Beam_rst_m.rvt.

Create a beam type

The new beam type is based on an existing beam that shares the same properties. You duplicate the type
properties and then modify the beam opening to the required size and shape.

1 Zoom in on one of the castellated beams.

2 Select the beam.

3 Click Element panel ➤ Element Properties drop-down ➤ Type Properties.

4 In the Type Properties dialog, click Duplicate.

5 In the Name dialog, type CB460X28.3 Custom, and click OK.

Modify the beam opening

You modify the beam by changing the size of the opening to allow for larger utility cables or similar services.
The values for the dimensions are listed in the Type Properties dialog and are displayed in the beam diagram.

6 In the Type Properties dialog, under Construction, do the following:

■ For e1 (Tee length), type 200 mm.

■ For e2 (Space between voids), type 150 mm.

■ For b (Length of sloped portion), type 100 mm.

■ For dt1 (Tee depth top beam), type 75 mm.

■ For dt2 (Tee depth bottom beam), type 75 mm.

■ Click Apply, and then click OK.
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NOTE Refer to the following diagram to identify each of the dimension parameters for the beam
opening.

Beam opening diagram

Apply the new beam type

Once the beam type is created, you apply the new type to an existing beam already placed in the project.

7 Select one of the remaining castellated beams.

8 Click Element panel ➤ Change Element Type drop-down ➤ CB460X28.3 Custom.
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Notice the openings in the beam have changed based on the new beam type.

9 Close the file with or without saving it.

You have completed this lesson on Creating a Custom Beam Type.
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Creating a Custom Deck
Family

In this lesson, you use the tools provided in Revit Structure, to modify the profile for a non-composite metal deck family
by adding a dovetail rib.

Skills used in this lesson:

■ Modify the reference planes of an existing profile

■ Add dimensions to the layout

■ Draw the dovetail above the deck profile

■ Create parameter labels to control the dovetail dimensions

■ Save the new profile into the families library

Creating a Custom Metal Deck Profile
In this exercise, you create a custom, non-composite metal deck family by adding a dovetail rib to the deck
profile.
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Open the metal deck family profile

You begin by opening an existing 2D profile for a non-composite deck. You then modify the vertical reference
planes to simplify the design and then place new dimensions to accommodate the shape of the new dovetail.

1 Click  ➤ Open ➤ Family.

2 In the left pane of the Open dialog, click Training Files, and open Metric\M_Form Deck_Non
Composite.rfa.

3 Click View tab ➤ Graphics panel ➤ Visibility and Appearance.

4 In the Visibility/Graphic Overrides dialog:

■ Click the Annotations Categories tab.

■ Under Visibility, click Dimensions and Reference Planes.

■ Click Apply, and then click OK.

5 In an empty part of the drawing area, right-click, and click Zoom to Fit.

6 On the View Control Bar, select 1:5 for scale.

Delete vertical reference planes

7 Select parameter wr as shown, and press Delete.

Delete the same parameter on the opposite side of the profile.

8 Delete additional vertical reference planes until the view appears as shown.
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Modify the angular reference plane

9 Click Create tab ➤ Dimension panel ➤ Angular.

10 Place a dimension for the angle as follows:

■ Click the horizontal reference plane.

■ Click the angle.

■ Move the cursor inside the profile, and click to place the dimension as shown.

11 Click Selection panel ➤ Modify.
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12 Select the angled reference plane, type 66, and press Enter.

13 Select the angular dimension and click the lock symbol to lock the angle to the horizontal
reference plane.

Using the same method, add an angular dimension for the angle on the opposite side of the
profile.

14 In an empty part of the drawing area, right-click, and click Zoom to Fit.

15 On the View Control Bar, select 1:2 for scale.

16 Click the top and bottom dimensions, and drag them as shown.
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17 Select the dimension that refers to the width of the profile base, and press Delete.

Repeat for the dimension on the opposite side.

Place new dimensions

You add dimensions to define the width, length, and height of the new profile. These dimensions are used
to control the parametric relationship of each element.

18 Click Dimension panel ➤ Aligned, and add a dimension as shown.
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19 Use the same method to add 2 two dimensions from the center reference plane to the bottom
of each side of the profile. Click the EQ symbol to apply equal constraints.

20 Click Selection panel ➤ Modify.

Add reference planes for the dovetail shape

You use both horizontal and vertical reference planes to draw the dovetail shape above the existing profile.

21 Zoom in around the top of the profile.

22 Click Datum panel ➤ Reference Plane.

23 Draw 1 horizontal and four vertical reference planes as shown.

24 Press Esc twice.

25 Select the five new reference planes that were placed, and click Element panel
drop-down ➤ Instance Properties.

26 In the Instance Properties dialog, under Other, for Is Reference, select Not a Reference, and then
click OK.

Dimension and constrain the dovetail

27 Click Create tab ➤ Dimension panel ➤ Aligned.

28 Add a dimension from the top of the profile to the dovetail horizontal reference plane as shown.
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The dimensions displayed in the following steps are provided for reference only and can be
customized based on your requirements.

29 Press Esc twice.

30 Select the horizontal reference plane, click the dimension, and type 9 mm, and press Enter.

31 Select the dimension line, and click the lock symbol to lock the distance to the horizontal
reference plane.

32 Using the same method, add the remaining dimensions for the dovetail as shown.

These dimensions refer to the positioning of the dovetail in relation to the profile center reference
plane.
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33 Click the EQ symbol to constrain the dimensions as shown.

Draw the dovetail

34 Click Detail panel ➤ Line.

35 Draw the dovetail by snapping to the intersections of the vertical and horizontal reference planes
as shown.

36 Click Modify.

37 Click Modify tab ➤ Edit panel ➤ Split, and on the Options bar, click Delete Inner Segment.

38 Using the split tool, trace the line between the dovetail and the existing element as shown.
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39 Click Selection panel ➤ Modify.

Create parameters a and b

You label the dimensions to create specific parameters for the dovetail. The dovetail is not considered
parametric until you add these labeled dimensions.

40 Select the lower dovetail dimension as shown.

41 On the Options Bar, click Label ➤ Add Parameter.

42 In the Parameters Properties dialog, under Parameter Data, type a for Name, click OK, and then
press Esc.

43 Select the upper dovetail dimension as shown.
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44 On the Options Bar, click Label ➤ Add Parameter.

45 In the Parameters Properties dialog, under Parameter Data, type b for Name, click OK, and then
press Esc.

Define wr parameter

46 Click Family Properties panel ➤ Types.

47 In the Family Types dialog, do the following:

■ For Name, select 50 X 150 mm.

■ Under Other, for wr, type 110 mm.

■ Click Apply, and OK.

48 Select the dimension as shown.

49 On the Options Bar, click Label, and select wr.
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Flex the new dovetail profile

50 Click Family Properties panel ➤ Types.

51 In the Family Types dialog, do the following.

■ Under Other, for a, type 40 mm.

■ Under Other, for b, type 50 mm.

■ Click Apply.
Notice that the dovetail adjusts automatically to the new parameters.

■ Click Cancel.

Save the new profile

52 Click  ➤ Save As ➤ Family.

53 In the left pane of the Save As dialog, click the Metric Library folder.

54 Click Profiles ➤ Structural folder, and for File Name, type M_Form Deck_Non
Composite_Dovetail.rfa, and click Save.

Create new parameters

55 Click Family Properties tab ➤ Types.

56 In the Family Types dialog, do the following.

■ Under Family Types, select Rename, and type 40 x 200 mm, and click OK.

■ Under Other, for a, type 40 mm.

■ Under Other, for b, type 50 mm.

■ Under Other, for Sr, type 200 mm.

■ Click Apply, and then click OK.

57 Click  ➤ Save.

This new family can now be used in any project.

You have completed this lesson on Creating a Custom Deck Family.
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Creating an In-Place Family

In this lesson, you create an in-place family for a step footing. You begin by opening a project with an incomplete
foundation wall and add a generic footing to the base of the wall. You then create an extrusion that forms the unique
shape of the step-footing rather than opening a generic footing from within a Family (.rft) template. In-place families
interact with the structural model according to their assigned family category.

Skills used in this lesson:

■ Create a family category

■ Draw an extrusion for the step footing

■ Change the extrusion properties

■ Copy the extrusion

■ Join the extrusion elements

7
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Creating a Step Footing In-Place Family
In this exercise, you create a step footing on an existing foundation wall.

Training File

■ Click  ➤ Open ➤ Project.

■ In the left pane of the Open dialog, click Training Files, and open Metric\In-Place-Footing_rst_m.rvt.

Place a footing at the base of the foundation wall

You begin by adding a footing at the base of the existing foundation wall.

1 Click Foundation panel ➤ Wall.

2 Click Element panel ➤ Change Element Type drop-down ➤ Wall Foundation: Bearing Footing
- 900 x 300.

3 Click the foundation wall.

The footing is placed at the base of the foundation wall.

Create a family category

You now create a family category for the solid extrusion that forms the shape of the step footing. You then
apply a material (concrete) to the element.

4 In the Project Browser, click Sections (Building Section) ➤ Section 1.

5 Zoom in on the foundation steps as shown.
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6 Click Home tab ➤ Model panel ➤ Component drop-down ➤ Model In-Place.

7 In the Family Category and Parameters dialog, select Structural Foundations, and click OK.

8 In the Name dialog, enter Structural Foundations 1 for Name, and click OK.

9 Click In-Place Modeling panel ➤ Solid drop-down ➤ Extrusion.

10 In the Work Plane dialog, select Pick a plane, and click OK.

11 Press Tab, and select the bearing footing as shown.

Make sure that the entire footing is selected.

Draw the extrusion

12 Click the corner of the footing to start the extrusion sketch as shown.

13 Using the drawing tools provided with Revit Structure, sketch a solid extrusion as shown.
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The dimensions have been added for reference purposes only.

14 On the Options Bar, for Depth, enter -900 mm.

15 Click Selection panel ➤ Modify.

Change extrusion properties

16 Click Element panel ➤ Extrusion Properties.

17 In the Instance Properties dialog, under Materials and Finishes, click the value for Material.

18 In the Materials dialog, for Name, select Concrete - Cast-in-Place Concrete, and then click OK.

19 In the Instance Properties dialog, click OK.

20 Click Extrusion panel ➤ Finish Extrusion.

21 Click In-Place Editor panel ➤ Finish Model.

Copy extrusion

22 Select the extrusion.

23 Click Modify panel ➤ Copy, and on the Options Bar, select Multiple.

24 Click the corner of the step foundation and the extrusion as shown.
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25 Click to place a second copy of the extrusion as shown.

26 Click to place a third copy of the extrusion as shown.

27 Press Esc.
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Join extrusion elements to the footing

You use the Multiple Join tool to join each extrusion to the footing element.

28 Click Modify tab ➤ Edit Geometry panel ➤ Join drop-down ➤  Join Geometry, and on the
Options bar, click Multiple Join.

29 Select the wall foundation.

30 Select the lower extrusion.

31 Select the middle extrusion.
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32 Select the upper extrusion as shown.

Join extrusion elements to each other

Finally, you use the Join Geometry tool to join the extrusions to each other to form a single in-place family.

33 Click Selection panel ➤ Modify.

34 Click Edit Geometry panel ➤ Join drop-down ➤  Join Geometry.

35 Select the middle extrusion.

36 Select the lower extrusion.
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37 Select the upper extrusion.

38 Press Esc twice.

39 In the Project Browser, click 3D Views ➤ 3D.
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40 Close the file with or without saving it.

You have completed this lesson on Creating a Step Footing In-Place Family.
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Creating a Titleblock
Family

In this tutorial, you create a custom titleblock sheet based on the A0 metric titleblock template.

The titleblock has linework, text, and labels. You customize the titleblock with a new text style, graphics, and your project
data.

Skills used in this tutorial:

■ Drawing lines for a titleblock

■ Adding a graphic to a titleblock

■ Adding text boxes to a titleblock

■ Adding labels to a titleblock

■ Adding a titleblock to a new project

8
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Drawing Linework for a Titleblock Sheet
In this exercise, you draw all of the linework necessary to create a custom A0-size sheet.

Open a titleblock template

1 Click  ➤ New ➤ Titleblock.

2 In the left pane of the New Title Block dialog, open Metric Templates\Titleblocks A1 metric.rft.

The default titleblock template consists of 4 border lines. The lines in the blank template represent
the edges of the paper. Custom page sizes can be created by changing the dimensions of these
lines.

Sketch the inside border

3 Click Create tab ➤ Detail panel ➤ Line.

4 Click Draw panel ➤  (Rectangle), and on the Options Bar, for Offset, type -25.

5 Click the upper left corner of the sheet to specify the first rectangle corner, and click the lower
right corner of the sheet to specify the second corner of the rectangle.

Add vertical and horizontal lines

6 Click Draw panel ➤  (Pick Lines), and on the Options Bar, for Offset, type 120mm.

7 Move the cursor over the right inside border line, and click to place a new vertical line.
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8 Click Draw panel ➤  (Line).

9 On the Options Bar, clear Chain, for Offset, type 0.

10 Draw a horizontal line 100mm below the upper inside border, as shown.

11 Draw a horizontal line 75mm below the last horizontal line, as shown.

12 Draw a horizontal line 100mm above the lower inside border as shown.
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13 Click Selection panel ➤ Modify, press Ctrl, and select the second and third horizontal lines.

14 Click Element panel ➤ Title Blocks drop-down ➤ Wide Lines.

NOTE The wide line style is not visible until the titleblock is loaded into a new project.

15 Press Esc.

16 Zoom in to the lower-right corner of the sheet.

17 Click Detail panel ➤ Line.

18 Click Draw panel ➤  (Pick Lines), and on the Options Bar, for Offset, type 20.

19 Move the cursor over the third horizontal line that you originally drew, and click to place a new
horizontal line 20mm below the existing line.

20 Using the same method, add 2 more horizontal lines below the existing lines, as shown.

21 On the Options Bar, for Offset, type 30.

22 Move the cursor over the third horizontal line, and click to draw a new horizontal line 30mm
above the existing line.

23 Using the same method, add 2 more horizontal lines above the existing lines, as shown.

24 Click Selection panel ➤ Modify.

25 Zoom out to view the entire sheet.

The titleblock linework is now complete.

26 Close the file with or without saving it.

In the next exercise, a new titleblock is supplied.
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Adding Graphics and Text to a Titleblock
In this exercise, you add a company logo, text notes, and labels to your titleblock.

Training File

■ Click  ➤  ➤ Open ➤ Family.

■ In the left pane of the Open dialog, click Training Files, and open Metric\Titleblock_blank_m.rvt.

Add a company logo

1 Click Insert tab ➤ Import panel ➤ Image.

2 In the left pane of the Import Image dialog, click Training Files, and open
Common\Company_Logo.jpg.

3 Place the image in the upper right corner of the sheet, and use the drag handles to resize the
image, as shown.

4 Zoom in to the logo.

Create a 10mm text style

5 Click Create tab ➤ Annotate panel ➤ Text.

6 Click Element panel ➤ Element Properties drop-down ➤ Type Properties.

7 In the Type Properties dialog, click Duplicate.

8 In the Name dialog, for Name, type 10mm Bold, and click OK.

9 In the Type Properties dialog, under Text, for Text Size, type 10, and select Bold.

10 Click OK.
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Add company name text

11 Draw a text box under the first horizontal line, as shown.

12 Type Arch Design Inc. in the text box.

13 Click outside of the text box to complete the text.

Add address and phone number

14 Click Element Panel ➤ Change Element Type drop-down ➤ Text : 8mm.

15 Draw a text box below the company name, and add an address and phone number, as shown.

Press Enter to add each new line of text and click outside of the text box to complete the text.
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16 Click Selection panel ➤ Modify, and select the last text note.

17 Select the drag handle, and drag the text note down, as shown.

18 Click outside the text box to complete the modification.

Add consultant information

19 Click Annotate panel ➤ Text.

20 Draw a text box below the second horizontal line, and type the following text:

■ Consultant:

■ Address:

■ Address:

■ Telephone:
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21 Click Selection panel ➤ Modify, and select the consultant text note.

22 Click Modify panel ➤ Copy.

23 On the Options Bar, verify Copy is selected, select Constrain and Multiple.

24 Click inside the Consultant text group.

25 Move the cursor down 100mm, and click to specify the first copied text note position.
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26 Move the cursor down another 100mm, and click to specify the second copied text note location.

27 Press Esc.
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Create a 5mm text style

28 Click Annotate panel ➤ Text.

29 Click Element panel ➤ Element Properties drop-down ➤ Type Properties.

30 In the Type Properties dialog, click Duplicate.

31 In the Name dialog, for Name, type 5mm, and click OK.

32 In the Type Properties dialog, under Text, for Text Size, type 5.

33 Click OK.

Add drawing data text

34 Click Element Panel ➤ Change Element Type drop-down ➤ Text : 5mm.

35 Draw a text box in the lower right space of the titleblock, and type Sheet Number:.

36 Using the same method, add the remaining text, as shown.

37 Press Esc.

Add drawing data labels

38 Click Annotate panel ➤ Label.

39 Click Alignment panel ➤ Horizontal ➤  (Right) and Vertical ➤  (Bottom).

40 Place the cursor at the lower right corner of the Date field, and click to specify the label location.

41 In the Edit Label dialog, under Category Parameters, select Project Issue Date, click the green
arrow to add it to the label, and click OK.

The label displays a default value wrapped to 3 lines.
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42 Select the left drag handle on the label, and drag to the left until the label displays on one line.

NOTE Move the label if necessary (using arrow keys) to line it up properly with the existing text.

43 Place the cursor at the lower right corner of the Drawn By field, and click to specify the label
location.

44 In the Edit Label dialog, under Category Parameters, select Drawn By, and click the green arrow
to add it to the label.

45 Click OK.

46 Place the cursor at the lower right corner of the Checked By field, and click to specify the label
location.

47 In the Edit Label dialog, under Category Parameters, select Checked By, click the green arrow
to add it to the label, and click OK.
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48 Press Esc.

Create a 15mm label style

49 Click Annotate tab ➤ Label.

50 Click Element panel ➤ Element Properties drop-down ➤ Type Properties.

51 In the Type Properties dialog, click Duplicate.

52 In the Name dialog, for Name, type 15mm Label, and click OK.

53 In the Type Properties dialog, under Text, for Text Size, type 15.

54 Click OK

Add sheet number and project data labels

55 Click Element Panel ➤ Change Element Type drop-down ➤ Label : 15mm Label.

56 Place the cursor at the lower right corner of the Sheet Number field, and click to specify the
label location.

57 In the Edit Label dialog, select Sheet Number, click the green arrow to add it to the label, and
click OK.

58 Click Alignment panel ➤ Horizontal ➤  (Center) and Vertical  (Middle).

59 Place the cursor near the center of the field above the Date field, and click to specify the label
location.

60 In the Edit Label dialog, select Project Number, click the green arrow to add it to the label, and
click OK.
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61 Select the left drag handle on the label, and drag to the left until the label displays on one line.

62 Place the cursor near the center of the field above the Project Number field, and click to specify
the label location.

63 In the Edit Label dialog, select Project Name, click the green arrow to add it to the label, and
click OK.

64 Place the cursor near the center of the field above the Project Name field, and click to specify
the label location.

65 In the Edit Label dialog, select Client Name, click the green arrow to add it to the label, and
click OK.
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Click Selection panel ➤ Modify, and using arrow keys, move any labels that need to be aligned.

Create a 4mm label style

66 Click Annotate tab ➤ Label.

67 Click Element panel ➤ Element Properties drop-down ➤ Type Properties.

68 In the Type Properties dialog, click Duplicate.

69 In the Name dialog, for Name, type 4mm Label, and click OK.

70 In the Type Properties dialog, under Text, for Text Size, type 4.

71 Click OK.

Add Project Path label

72 Click Element Panel ➤ Change Element Type drop-down ➤ Label : 4mm Label.

73 Click Alignment panel ➤ Horizontal ➤  (Left) and Vertical ➤  (Middle).

74 Place the cursor in the border area below the Sheet Number field, and click to specify the label
location. (Left-align the label with the Sheet Number field.)

75 In the Edit Label dialog, select File Path, click the green arrow to add it to the label, and click
OK.

76 Click Selection panel ➤ Modify, and then adjust the width of the File Path field so that it is
approximately equal to the width of the Sheet Number field.
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77 Close the file with or without saving it.

In the next exercise, a completed titleblock is supplied.

Adding the Titleblock to a New Project
In this exercise, you add the titleblock that you created to a new project.

Load the titleblock family into a project

1 Click  ➤ New ➤ Project.

2 In the New Project dialog, under Template file, click Browse.

3 In the left pane of the Choose Template dialog, open Metric Templates\Structural
Analysis-DefaultMetric.rte.

4 Under Create new, verify that Project is selected, and click OK.

5 Click View tab ➤ Sheet Composition panel ➤ Sheet.

6 In the Select a Titleblock dialog, click Load.

7 In the left pane of the Open dialog, click Training Files, and open
Metric\Titleblock_complete_m.rvt, select it, and click Open.

8 In the Select a Titleblock dialog, select Titleblock_complete_m, and click OK.

Modify titleblock properties

9 Select the titleblock.

10 Click Element panel ➤ Element Properties drop-down ➤ Instance Properties.

11 In the Instance Properties dialog, under Other, for Drawn By, type Name, and click OK.

12 Zoom in to the lower-right corner of the sheet.
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13 Click Manage tab ➤ Project Settings panel ➤ Project Information.

14 In the Instance Properties dialog:

■ For Project Issue Date, type January 1, 2008.

■ For Project Status, type In Progress.

■ For Client Name, type Jane Smith.

■ For Project Name, type Office Building.

■ For Project Number, type 2008-01.

15 Click OK.

16 Zoom to fit the titlesheet in the view.

17 Close the project with or without saving it.

This completes the Creating a Titleblock Family lesson.
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